Error: Can't initialize nvrm channel

Hi all,

I am receiving the message Error: Can’t initialize nvrm channel over and over in the terminal. I can’t reproduce exactly what causes that error message but it appeared while trying out the TensorFlow/TensorRT Models on the Jetson TX2. Specifially, while running the jupyter notebook detection.ipynb. Even after stopping the Jupyter Notebook, the error message is printed in the original terminal window. Ctrl+C stops it only for a few seconds. My current fix is using a new terminal window but I wanted to find out what the problem is.

Regarding the jupyter notebook, I get the following output after running this block:

trt_graph = trt.create_inference_graph(
    input_graph_def=frozen_graph,
    outputs=output_names,
    max_batch_size=1,
    max_workspace_size_bytes=1 << 25,
    precision_mode='FP16',
    minimum_segment_size=50
)

Does anyone have an idea, what the problem might be?

Hi,

Generally, nvrm issue is related to camera pipeline.
Do you try to open a camera as input inside your ipython code?

For “Error: Can’t initialize nvrm channel”, maybe this comment will help:
https://devtalk.nvidia.com/default/topic/1030976/jetson-tx2/camera-not-working-with-gst-launch-command-onboard-camera-/post/5247347/#5247347

If you didn’t try to open a camera, some further investigation is required.
Thanks.

Hi AastaLLL,

No, in the Jupyter Notebook a local image is loaded and then processed. No input from a camera needed.

As this problem was pretty urgent, I reset the whole system and flashed the TX2 again. The error message is not showing up anymore and the Jupyter notebook now works as well after adding the Kernel for Python 3.

This might not be a practical solution for other people with the same problem but for now there is no further investigation required from my side.

Thank you

Hi

I had the same error. But it went away when I installed pillow.

pip3 install pillow

Sojohans

Hi

Also had the same error and realized it was happening when I had no Web Browser open (the only one installed is Chromium). Then command jupyter notebook would open Chromium and prompt the window “Unlock Login Keyring”, this will cause the error to keep repeating since it wasn’t able to fully run the jupyter notebook command.

It hasn’t happened again after having properly opened Chromium before running jupyter notebook for the “first time”

1 Like

Hi,

I am also facing the same issue. As soon as I run ‘jupyter notebook --ip=0.0.0.0’, Jupyter notebook starts and in the terminal I get ‘Error: Cant initialize nvrm channel’

I also installed pillow but that didnt help.

Any updates on this issue?

I think I have a case where it is easily reproducible when trying to run the electron tutorial
You will need to have node installed (which also installs npm ) and git to run it.

After running “npm start” the terminal window will repeatedly display the error message
“Error: Can’t intitialize nvrm channel”

# Clone the repository
$ git clone https://github.com/electron/electron-quick-start
# Go into the repository
$ cd electron-quick-start
# Install dependencies
$ npm install
# Run the app
$ npm start

Hi,
This is similar to https://devtalk.nvidia.com/default/topic/1052333/jetson-tx2/error-can-t-initialize-nvrm-channel/post/5342301/#5342301

A workaround for me is the option

jupyter notebook --no-browser

You can then launch the notebook from your localhost manually (e.g. localhost:8080).
This works as well with ssh and tunnel forwarding.
I did not get the nvrm error using this approach.

1 Like

Does anyone have any idea what is causing this? I understand there are work-arounds for some applications, but I don’t know much about jupyter. Electron is built on top of Chrome. Is that the common connection? Someone suggested it is related to a camera, but Electron is not using a camera at all. Just wondering.

Hmm, interesting, I am seeing this error too. I didn’t notice it before, so I can’t say if it’s new or if it was always like that, but I just noticed it today.

And as Max_TUM states, if you do --no-browser launch and then copy the localhost address with token, the error does not happen.

I don’t see this on my desktop, but I do see:

[6873:6873:0626/161606.219758:ERROR:sandbox_linux.cc(368)] InitializeSandbox() called with multiple threads in process gpu-process.
Opening in existing browser session.
[6839:6855:0626/161606.244348:ERROR:browser_process_sub_thread.cc(221)] Waited 4 ms for network service

at the startup, while this is not seen if doing --no-browser launch.

And on Jetson, when quitting out of the browser window, I see similar “browser_process_sub_thread.cc(221)” error at exit.

Is there anything happening with this? It is easily reproducible if you install electron. I am doing quite a bit of electron work and while it isn’t a show stopper, it is a nuisance to have my terminal fill up with this message. Even a way to turn it off would be nice.

The current solution is
https://devtalk.nvidia.com/default/topic/1052333/jetson-tx2/error-can-t-initialize-nvrm-channel/post/5350512/#5350512

We are still checking this issue.

So, did you ever find a solution?
I am having the same issue now while using xdb-open to open web pages.

1 Like

I’m having the same issue. Any updates?

hi i have deployed node.js and electron both on Jetson Nano 4gb. when i try to run it from terminal, i get the same error.

I also tried to run a packaged electron app having arm64 architecture but still the same error.

i tried this command
$ chromium-browser --disable-gpu

but still no luck.

I downloaded jetson nano image on 3rd june 2021 so i suppose it will have latest jetpack.

any update on this issue?

thanks
raxit

I had the same issue on a Jetson Nano running julia.
After giving the electrondisplay(df) command, the Electron window opened , blank, and
julia> electrondisplay(df)
Error: Can’t initialize nvrm channel
Error: Can’t initialize nvrm channel
Electron.Window(Application(Base.PipeEndpoint(RawFD(27) paused, 0 bytes waiting), Process(/home/andrew/.julia/artifacts/bf8267793953d41b83f2b9bfb4209fe2547b0e33/electron /home/andrew/.julia/packages/Electron/ILvWR/src/main.js /tmp/jlel-532c403ccdcd11eb239e09ad5a0902ad /tmp/jlel-sn-532c9c2ecdcd11eb3796255d73b89517 JxB5kU5lAEmsaTrM/eFUR4kA4n37PAYrpLglNoQZLAmsexqswduvxc2ZzW9+UoOQW4R50AtYZpCzhDyrPbUdyBMzeBOdTWbDU41d5Q7mYCWoGLPqs1jLCN29W1oj8ZT8DUdU5vOh/FXXhftxB+gnSrKdaku3+ECj9WPcR3m3SOc=, ProcessRunning), [1 window]), 1, true, Channel{Any}(128))

I had to add my user to a bunch of groups:
sudo usermod -aG
This was the list of groups i had to add my user to:
adm cdrom sudo audio dip video plugdev i2c lpadmin gdm lightdm gpio weston-launch sambashare

Some of these may be redundant/unneeded, but this fixed my problems.