Error: cuda: Depends: cusa-10-1 (>=10.1.168) but it is not installed

hi!,

I am running linuxmint 18.3 Sylvia and I have GEFORCE 920MX and I get an error message after I installed CUDA toolkit version 10.1 and 10.0 that

cuda: Depends: cuda-10-1 (>=10.1.168) but it is not installed

I try to install cuda 10.1 and cuda 10.0 with this links:

https://developer.nvidia.com/cuda-downloads?target_os=Linux&target_arch=x86_64&target_distro=Ubuntu&target_version=1804&target_type=deblocal

https://developer.nvidia.com/cuda-10.0-download-archive?target_os=Linux&target_arch=x86_64&target_distro=Ubuntu&target_version=1804&target_type=deblocal

I followed all instructions, but when I execute sudo apt-get install I get the same error in both cases

Thank for any help!

Try searching around the installation forums a bit because this exact question has been answered a number of times in recent days.
It is really just linux package handling. It is possible that you will need to remove the cuda-related packages that are on your system and reinstall the meta-package.

yes I trying to find something but i don’t find nothing, sorry. I never installed any version of cuda in my pc y don’t know what to do. I reinstalled all my sistem and i have de same error

Read this post here, which has kind of the same problem as everyone else who reports it, and adjust to your version:
https://askubuntu.com/questions/940582/upgrade-or-uninstall-cuda-to-allow-apt-get-to-work

If it doesn’t work, remove the thing again with the package manager and use the runfile installer. If you decide to keep the driver installed by the package manager, then don’t install the one that comes in the runfile, install just the toolkit.

You can probably try:

This may be of interest:

https://devtalk.nvidia.com/default/topic/1043184/cuda-setup-and-installation/cuda-install-unmet-dependencies-cuda-depends-cuda-10-0-gt-10-0-130-but-it-is-not-going-to-be-installed/post/5362151/#5362151