Error Flashing TX1, Return value 4

Hi,

I receive the following error when trying to flash a TX1 with 28.2.0:

Error: Return value 4
Command tegradevflash --oem platformdetails storage storage_info.bin
Failed flashing t210ref.

I have tried several TX1s, and have received the same error.

I am trying to flash the image as per the instructions here: https://www.dropbox.com/sh/8szy4ypah7sv3d8/AADTwVu9oMPRmvKMMpVm-AYSa?dl=0&preview=l4t_quick_start_guide.txt

Thanks!

Hi vviswan2,

Please try with JetPack 3.3 - https://developer.nvidia.com/embedded/jetpack-3_3

Thanks

Hi vviswan2,

After untar the files, are you run below steps?

$ sudo ./apply_binaries.sh

yes, I did.

I will try with Jetpack 3.3 now

I tried with Jetpack 3.3, but I had the following errors:

[   6.9929 ] Updating BFS information
[   6.9953 ] tegrabct --bct P2180_A00_LP4_DSC_204Mhz.bct --chip 0x21 --updatebfsinfo flash.xml.bin
[   6.9982 ]
[   6.9982 ] Boot Rom communication
[   7.0008 ] tegrarcm --chip 0x21 --rcm rcm_list_signed.xml --skipuid
[   7.0031 ] RCM version 0X210001
[   7.5785 ] Boot Rom communication failed
[  15.2670 ]
Error: Return value 3
Command tegrarcm --chip 0x21 --rcm rcm_list_signed.xml --skipuid
Failed flashing t210ref.

Please see full logfile attached.
flash_os_64_tx1.log (160 KB)

Boot ROM communications failed. Are you using a VM? If so, then you need to make sure the VM owns the device at all times, even after disconnect and reconnect. If not, then it is something else, perhaps even a bad cable (is it the original cable?).

Hi vviswan2,

As linuxdev mentioned, are you using VM?
Please check your host Ubuntu machine, we are support 16.04 and 18.04. Thanks!

HI, I am not using a VM. I was using a 16.04 host machine, and the cable has worked for other cases (flashing the TX2).

It sounds like it should work. I still would like to know if it is the original cable which arrived with one of the Jetsons?

You may also want to try flashing from a different host port, or perhaps with and without a HUB (but put only the Jetson being flashed on the HUB if you test with a HUB).

There might be an actual failure, but knowing the above would remove a lot of guessing.

Hi vviswan2,

Please try below method, we can find the root case:

  1. Try plug-in USB cable to others USB port on host
  2. Untar the image and flash by manually again
  3. Using JetPack-3.3 to flash image
    https://developer.nvidia.com/embedded/dlc/jetpack-l4t-3_3

Hi @carolyuu,
I am facing the same issue with Jetpack 4.4 on Jetson Nano after I run the flash command.