Error" Pytorch 2.1.0 with Python 3.9 wheel file not supported on this platform: ERROR


I am getting the below error after building wheel file for pytorch version 2.1.0 with python 3.9.
Pls let us know how to fix this issue for the same.

Find the below thread related to building pytorch 2.10 with python 3.9:

@nagesh_accord are you sure you are trying to install it with the Python 3.9 version of pip? What does pip3 --version show?

It says python 3.8

How to change it to python 3.9

I hope this python 3.8 which was installed as part of Jetpack installation along with CuDA won’t have any effect, if uninstalled or changed to python 3.9

Thanks a lot for the response.

After changing the soft link of /usr/bin/python3 to Pyhon3.9 through “ln” command, I was able to install the pytorch .whl file built for python3.9.


  1. I need to similarly install tensor Flow v0.16.1 for compatible for pytorchv2.1 with Python3.9.
    Pls provide steps to build the same and install it.

I have raised below thread for the same. Kindly reply to it. Thanks.

Hi @nagesh_accord, glad you were able to get your PyTorch 3.9 installed! Sorry I haven’t built TensorFlow myself before, but I see @AastaLLL is on your other topic.

1 Like


I was able to install tensorflow also some how successfully.

I got the wheel.file from.tensorflow website of version 2.16 but for jet pack 5.1.2 it should be 2.12.
Hope.during future programming this tensor flow does not give any issues with any errors. Pls confirm.

Also I am having issues with torch vision installations with the steps provided in the documentation link tagged by you.

Pls check the other thread and let me know.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.