Error while installing cuda on Host

  1. I have l4t 4.6 installed using the SDKManager
  2. I try to install 4.5.1 using the SDKManager and get a CUDA build error
14:42:28 INFO: CUDA Cross Compile Package on Host - host: Some packages could not be installed. This may mean that you have
14:42:28 INFO: CUDA Cross Compile Package on Host - host: requested an impossible situation or if you are using the unstable
14:42:28 INFO: CUDA Cross Compile Package on Host - host: distribution that some required packages have not yet been created
14:42:28 INFO: CUDA Cross Compile Package on Host - host: or been moved out of Incoming.
14:42:28 INFO: CUDA Cross Compile Package on Host - host: The following information may help to resolve the situation:
14:42:28 INFO: CUDA Cross Compile Package on Host - host: The following packages have unmet dependencies:
14:42:28 INFO: CUDA Cross Compile Package on Host - host: cuda-cross-aarch64-10-2 : Depends: cuda-cufft-cross-aarch64-10-2 (>= 10.2.89)14:42:28 INFO: CUDA Cross Compile Package on Host - host: Depends: cuda-curand-cross-aarch64-10-2 (>= 10.2.89)
14:42:28 INFO: CUDA Cross Compile Package on Host - host: Depends: cuda-npp-cross-aarch64-10-2 (>= 10.2.89)
14:42:28 ERROR: CUDA Cross Compile Package on Host - host: E
14:42:28 ERROR: CUDA Cross Compile Package on Host - host: :
14:42:28 ERROR: CUDA Cross Compile Package on Host - host: Unable to correct problems, you have held broken packages.
14:42:28 INFO: CUDA Cross Compile Package on Host - host: [ Package Install Finished with Error ]
14:42:28 INFO: CUDA Cross Compile Package on Host - host: [host] [ 16.00 KB used. Disk Avail: 57.96 GB ]
14:42:28 INFO: CUDA Cross Compile Package on Host - host: [ NV_CUDA_CROSS_HOST_COMP Install took 5s ]
14:42:28 ERROR: CUDA Cross Compile Package on Host - host: [error]: Error when apt install failed; [exec_command]: sudo apt-get update; sleep 0.5; sudo apt-get -y install cuda-cross-aarch64-10-2=10.2.89* ; [error]: exit status 100; [deb_path]: /home/asei/Downloads/nvidia/sdkm_downloads/cuda-repo-cross-aarch64-10-2-local-10.2.89_1.0-1_all.deb
14:42:28 ERROR: CUDA Cross Compile Package on Host - host: command terminated with error
14:42:28 SUMMARY: CUDA Cross Compile Package on Host - host: First Error: APT system is broken and requires manual fix

Here is the full Log

SDKM_logs_JetPack_4.5.1_Linux_for_Jetson_AGX_Xavier_2021-08-26_14-37-23.zip (145.8 KB)

There is another post similar to this: [Error while installing cuda on Host and Deepstream on target]
(Error while installing cuda on Host and Deepstream on target)

I am hesitant to do the sudo dpkg --purge <cuda_packages_listed_above> because of the 4.6 install.

Sorry for the late response, we will do the investigate to do the update soon.

Hi,

Could you try to uninstall the JetPack 4.6 package via SDK manager first?
You can find it at STEP01 from the SDK manager.

Thanks.

I created a new VM and only loaded the 4.5.1 version and all is well with the SDKManager.

~WRD0001.jpg