Error installing CUDA on host

Hello, I am trying install jetpack 4.4. I am facing few issues with SDK manager
CUDA and Computer vision installation error.
My error is exactly similar to (Error while installing cuda on Host and Deepstream on target)
I followed the following steps

  1. Use dpkg -l | grep cuda command to list all CUDA packages.
  2. Use sudo dpkg --purge <cuda_packages_listed_above> command to remove CUDA packages one by one
  3. Reinstall CUDA
    and also i followed this step Error while installing cuda on Host and Deepstream on target - #8 by Bazziil
    But I am facing the same error again
    ERROR: CUDA on Host: E: Unable to correct problems, you have held broken packages.
    I successfully installed jetpack 4.6 a few weeks ago.But, for my project, I needed to install Jetpack 4.4, so when I tried to install it, these issues began to appear, and if I tried to install the same Jetpack 4.6, the same errors appeared.

Any help or advise on this subject would be greatly appreciated!


Would you mind removing the CUDA toolkit via SDKmanager first?
You can find this option in the bottom left corner.

Repair/Uninstall → Uninstall → …


I did that too. Still same broken packages.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.


Would you mind sharing the complete SDK manager log with us first?
This file can be generated via EXPORT LOGS button.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.