Error while using Compute Visual Profiler

Hi all, I was trying to check the execution time of my CUDA program using Compute Visual Profiler. However,

when I tried to launch the program, it constantly gave error message:

"Error in profiler data file. '.../temp_compute_profiler_0_0.csv' at line number 1. No column found"

I’ve checked the User Guide of Compute Visual Profiler, but it mentions nothing about this kind of error. I’ve tried to run my program on terminal and there was no error (including seg fault error).

What should I do to tackle this problem? Is this related to the launching of my kernel? If so, what is the best way to check whether my kernel was launched appropriately?

Thanks in advance… I appreciate you helps…

:smile:

It’s a while back since I last used the profiler. I seem to vaguely remember this message can appear if you don’t (successfully) launch any kernels?

That’s it. I’m not quiet sure whether my kernel was launched successfully or not.

But I tried to give a printf line inside the kernel, and when I executed my program, the printf message appear many times (because there are many threadIdx.x). Does the error message of

temp_compute_profiler_0_0.csv' at line number 1. No column found

can only appear only if the kernel was failed to launch? Is there any possibility?

:confused: