Error with installing SDK Manager

Hi everyone,

I’m follow the installation instructions on this link to install the NVIDIA SDK Manager on my Jetson Nano, and I get the following error message.

leonardo@leonardo-desktop:~$ sudo apt install ./sdkmanager_1.4.0-7363_amd64.deb
[sudo] password for leonardo:
Reading package lists… Done
E: Unsupported file ./sdkmanager_1.4.0-7363_amd64.deb given on commandline

I just want to install Nsight Visual Studio to use CUDA in my jetson Nano. But I am not able to install the SDK manager, why is this happening?

Can you try this command:
sudo dpkg -i ./sdkmanager_1.4.0-7363_amd64.deb

dpkg: error processing archive ./sdkmanager_1.4.0-7363_amd64.deb (–install):
package architecture (amd64) does not match system (arm64)
Errors were encountered while processing:

Is it possible to install Nsight Visual Studio directly on the jetson nano?

SDK Manager is used only on the desktop PC Ubuntu 18.04 host PC. This cannot be directly installed to the Jetson. Once on the PC you can uncheck flash and just install extra packages, but I think part of what you want will not run directly on the Jetson. Nsight Visual Studio was also intended to go only on the PC.

I also have the same error when I try to install the SDK Manager on my Ubuntu host PC.
Then I also tried using the sudo dpkg format and this error occurred:

dpkg: error: need an action option

@l.miguel It’s not possible. It only works on Windows OS

Operating System Requirements Minimum Requirements:
Minimum Requirements:

* Windows HPC Server 2016 (64-bit) or Windows 10 RS4 (build 1803)
* 64-bit

Note: 32-bit operating systems are no longer supported with Nsight™ Visual Studio Edition 5.0 or later.
Note: windows 7 systems are no longer supported with Nsight™ Visual Studio Edition 2020.1 or later.

@janmichael.panelo Someone got the same error. They solved this problem to type:

sudo dpkg --install <debian_package_path>

instead of

sudo dpkg -i <debian_package_path>