Jetson Nano - Nsight Systems target not supported

I used newest version (currently 06.18.2023) of nsight systems.

  • Nsight Systems 2023.2.1 (Linux Host .run Installer)

I opened nsys-ui and used the ssh options.

The problem is that when ssh into Jetson Nano, it shows this message. The Jetpack version is 4.6.3.

Target is not supported

This version of Nsight Systems does not support profiling on the selected target.

Missing directory with target binaries:


More info.

DirectoryNotFoundError (150) {

OriginalExceptionClass: N5boost10wrapexceptIN11QuadDCommon26DirectoryNotFoundExceptionEEE

OriginalFile: /dvs/p4/build/sw/devtools/Agora/Rel/QuadD_Main/QuadD/Host/Analysis/PosixDeviceValidator.cpp

OriginalLine: 24

OriginalFunction: bool QuadDAnalysis::PosixDeviceValidator::CheckHostSupport(const DevicePtr&)

Filename: /home/jake/nsight-systems-2023.2.1/target-linux-tegra-armv8

ErrorText: Deploy directory does not exist


The main problem is that when installing Nsight systems, target-linux-tegra-armv8 this does not exist, which is needed for profiling Jetson Nano. All of the versions below failed. Is there anything I should try?

Versions Tried

Tried multiple environments and versions of Nsight.


Ubuntu 20.04

  • Nsight Systems 2023.2.1 (Linux Host .run Installer)

  • Nsight Systems 2022.5.1 (Linux Host .run Installer)

  • Nsight Systems 2022.1.1 (Linux Host .run Installer)

  • This version has target-linux-sbsa-armv8, however is not for Jetson Nano.

  • Nsight Systems 2020.5.1 (Linux Host .run Installer)

  • Nsight Systems 2019.5.1 (Linux Host .run Installer)

Ubuntu 18.04

  • Nsight Systems 2023.2.1 (Linux Host .run Installer)

  • Nsight Systems 2022.5.1 (Linux Host .run Installer)

Linux Server

Ubuntu 22.04

  • Nsight Systems 2023.2.1 (Linux Host .run Installer)

Virutal Machine

Used VMWare Workstation 17 Player

Ubuntu 20.04-desktop

  • Nsight Systems 2023.2.1 (Linux Host .run Installer)

This is the Jetpack package.

Package: nvidia-jetpack
Version: 4.6.3-b17
Architecture: arm64
Maintainer: NVIDIA Corporation
Installed-Size: 194
Depends: nvidia-l4t-jetson-multimedia-api (>> 32.7-0), nvidia-l4t-jetson-multimedia-api (<< 32.8-0), nvidia-cuda (= 4.6.3-b17), nvidia-tensorrt (= 4.6.3-b17), nvidia-nsight-sys (= 4.6.3-b17), nvidia-cudnn8 (= 4.6.3-b17), nvidia-opencv (= 4.6.3-b17), nvidia-container (= 4.6.3-b17), nvidia-vpi (= 4.6.3-b17)
Priority: standard
Section: metapackages
Filename: pool/main/n/nvidia-jetpack/nvidia-jetpack_4.6.3-b17_arm64.deb
Size: 29368
SHA256: 694254a8667ebbf13852548bdd13a5b8ae61481ac059845b706398eefdcb9e01
SHA1: 67140fc8463ec61fd69352b225244b639c799edd
MD5sum: afa1382b6caded6b736d494fc481bab4
Description: NVIDIA Jetpack Meta Package
Description-md5: ad1462289bdbc54909ae109d1d32c0a8

For Jetson Nano, you need to use the embedded version (Tegra version) available as part of JetPack: JetPack SDK | NVIDIA Developer

You indicate that that version is not working either. @Andrey_Trachenko can you assign an engineer to look into this one?

Hello @jakio,

Thank you for posting and I’m sorry that you had trouble picking the correct version of Nsight Systems.

As Holly mentioned, for all Jetson devkits, please use JetPack SDK - JetPack SDK | NVIDIA Developer. It comes with all the tools included. Speficially, with JetPack 4.6.3, you would receive Nsight Systems 2021.5.4.

Newer versions of Nsight Systems ship with JetPack 5.x, which unfortunately doesn’t support Jetson Nano (Xavier-based). Newer version of Nsight Systems may work with older version of Jetson devkits to some extent, but these combinations are not tested, and I’m a bit hesitant to recommend you to spend time trying such a combination.

@Andrey_Trachenko I totally understand that I need the jetpack sdk, and I downloaded the sdk image from this link.

Am I doing it wrong? Or is there a different way?

The problem is that I can’t even check if nsight is included in my installed jetpack.

Thank you.

The SD card image does not contain Nsight Systems.

Please follow the instructions to install JetPack SDK on your host Ubuntu machine, and this is where you can select Nsight Systems to be installed (and maybe deselect other components that you don’t need). Once it is installed, it would be possible to open Nsight Systems on your host Ubuntu, and connect to the Jetson over SSH.

The key thing is that you need to use Nsight Systems 2021.5.4, which shipped as part of the JetPack 4.6.3.

@Andrey_Trachenko Thanks for your information.

Do you mean installing using the SDK manager?

Thank you.

I’m still not getting how to use the SDK manager. The part I’m stuck with is connecting the board to the Host Ubuntu 18.04 machine.

It says Could not detect a board.

I found some tutorials using the Jetson Xavier board, and found out that I have to put the board in ‘recovery mode’ and connect it.

However, there are some differences with the Xavier, that it doesn’t have a USB C port to connect.

I’m curious if there is any tutorial that I could follow, to install the Nano.

Thank you.

Thank you @jakio, let me see if someone who knows SDK Manager better than me can help here, and we’ll get back to you.

If a board is first time with SDK Manager, it may not be able to get detected in normal mode. You can ignore the message, click “continue”, start the installation. When the pre-flash dialog pop up, selecet “manual setup - your board type”, it will guide you how to set the board to recovery mode.