Not found Nsight Systems 2021.5.4 version for Ubuntu 20.04

I have Jetson AGX Xavier installed nsight-system 2021.5.4 as a part of Jetpack 4.6. My PC is running Ubuntu 20.04. I tried to install Nsight Systems 2021.5 on my PC.1 but i got below error.

DirectoryNotFoundError (150) {
    OriginalExceptionClass: N5boost16exception_detail10clone_implIN11QuadDCommon26DirectoryNotFoundExceptionEEE
    OriginalFile: /build/agent/work/20a3cfcd1c25021d/QuadD/Host/Analysis/PosixDeviceValidator.cpp
    OriginalLine: 24
    OriginalFunction: bool QuadDAnalysis::PosixDeviceValidator::CheckHostSupport(const DevicePtr&)
    Filename: /opt/nvidia/nsight-systems/2021.5.1/target-linux-tegra-armv8
    ErrorText: Deploy directory does not exist

On my Jetson just have : opt/nvidia/nsight-systems-cli/2021.5.4/target-linux-tegra-armv8 folder, so i want to install Nsight Systems 2021.5.4 version for my PC but i dont found it.
Can you help me fix it?
Thank you very much

Hi, the normal way of installing from Jetpack is to install Jetpack (and therefore Nsys) on your host machine. The transfer of the needed filed to the jetson system happens on the first requested profile.

From the user’s guide:

3.2. Installing GUI on the Host System

Copy the appropriate file to your host system in a directory where you have write and execute permissions. Run the install file, accept the EULA, and Nsight Systems will install on your system.

On Linux, there are special options to enable automated installation. Running the installer with the --accept flag will automatically accept the EULA, running with the --accept flag and the --quiet flag will automatically accept the EULA without printing to stdout. Running with --quiet without --accept will display an error.

The installation will create a Host directory for this host and a Target directory for each target this Nsight Systems package supports.

All binaries needed to collect data on a target device will be installed on the target by the host on first connection to the device. There is no need to install the package on the target device.

Hi, I have the same error. I flashed Jetson in a different way than Jetpack SDK before. Now I’m using a Macos to profile a Jetson Orin-NX 16 GB JP 5.1.1(L4T) custom carrier board and I get the same error. What do I need to do right now?

Macos nsight version: 2023.4
Jetson nsight version: nsight-systems-2022.5.2

DirectoryNotFoundError (150) {
    OriginalExceptionClass: N5boost10wrapexceptIN11QuadDCommon26DirectoryNotFoundExceptionEEE
    OriginalFile: /dvs/p4/build/sw/devtools/Agora/Rel/QuadD_Main/QuadD/Host/Analysis/PosixDeviceValidator.cpp
    OriginalLine: 26
    OriginalFunction: bool QuadDAnalysis::PosixDeviceValidator::CheckHostSupport(const QuadDAnalysis::DevicePtr &)
    Filename: /Applications/NVIDIA Nsight
    ErrorText: Deploy directory does not exist