Jetson Nano & Nsight Eclipse Edition?

Does Jetson Nano support Nsight Eclipse Edition?
The CUDA Toolkit documentation indicates that ‘nsight’ should be in /usr/local/cuda/bin but there is none.

Where can I find Nsight Eclipse Edition?

You need to install Nsight Eclipse on the Ubuntu host machine. Then you can cross compile the apps and remote debug the applications on Jetson. Please check https://devblogs.nvidia.com/cuda-jetson-nvidia-nsight-eclipse-edition/

Hi There,

The instructions on that page don’t seem to work.

The cross stuff is not available in cuda-repo-ubuntu1804-10-1-local-10.1.105-418.39_1.0-1_amd64.deb

“sudo apt-cache search cuda-cross” returns nothing.

The only target available in /usr/local/cuda/targets/ is x86_64-linux

Can anyone help me getting nsight working on Ubuntu for the Nano?

Many thanks

Andy

Hi,

Please follow the instructions here to install the cross platform packages:
https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#cross-platform

You need to install the bits using “sudo apt-get install cuda-cross-aarch64”

Hi,

Thanks for the reply.

Sorry I didn’t explain myself properly.

cuda-cross-aarch64 is not contained in cuda-repo-ubuntu1804-10-1-local-10.1.105-418.39_1.0-1_amd64.deb, so apt-get install doesn’t find it. You can use apt-cache search and it also doesn’t find any of the cuda-cross components.

I got around this by using sdkmanager to install everything and that worked fine.

Cheers

Andy

Hi Andy,

Can you describe the steps for installing NSight Eclipse using sdkmanager?
Or, if available, share the link to the procedure?

I appreciate your help and thank you in advance,

Sidney

Hi Sidney,

The download page is here: https://developer.nvidia.com/embedded/downloads

The deb file is here: https://developer.nvidia.com/embedded/dlc/nv-sdk-manager

Instructions here: https://docs.nvidia.com/sdk-manager/download-run-sdkm/index.html

I just selected everything for the install, when you get to the bit to flash the Nano just cancel it the two times.

Good luck :)

Cheers

Andy

Hi Andy, thanks for the quick reply and the information. Have a great rest of the day!

Hi Andy,

I followed the installation instructions for the sdkmanager but it didn’t work for me. Did you experience the same? If so, how did you resolve it?

$ sudo apt install ./sdkmanager_0.9.11-3405_amd64.deb

[i]Reading package lists... Done Building dependency tree Reading state information... Done Note, selecting 'sdkmanager:amd64' instead of './sdkmanager_0.9.11-3405_amd64.deb' Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies:
sdkmanager:amd64 : Depends: libgconf-2-4:amd64 but it is not installable
Depends: libcanberra-gtk-module:amd64 but it is not installable
E: Unable to correct problems, you have held broken packages.
[/i]
</error message>

Hi Sidney,

No, it worked fine here.

I just had a search and found this: https://devtalk.nvidia.com/default/topic/1049925/error-with-installing-nvidia-sdk-manager-you-have-held-broken-packages-/

So maybe try with:

sudo dpkg -i ./sdkmanager_0.9.11-3405_amd64.deb && apt update -f

Cheers

Andy

Hi Andy,

I used the links that you provided, but got the same errors as Sidney. Also tried this:

sudo dpkg -i ./sdkmanager_0.9.11-3405_amd64.deb && apt update -f

but got this error:

dpkg: error processing archive ./sdkmanager_1.3.0-7105_amd64.deb (–install):
package architecture (amd64) does not match system (arm64)

Did you do something different to install de SDKmanager?

Thanks in advance,
Carlos