Nsight eclipse does not install when installing CUDA 6.0

got the Jetson TK1, went through the steps to install CUDA, OpenCV, ArrayFire, etc (all the steps in the getting started and elinux page).

I am wanting to start getting up to speed on programming for CUDA (compiling directly on the Jetson no cross comilation yet) and documentation says I can use NSight Eclipse which installs when you install CUDA. Well, i cannot find nsight anywhere in my file system (I did find a few .xml files that had nsight in the name) but nsight seems to not have been installed with the toolkit. Been searching to no avail except for a few data points that may be similar ((1) someone in the forum said something about cuda 6.0 not running well on ubuntu 14.04, maybe related (2) someone in a forum said when installing cuda from .deb package that the toolkit doesn’t completely install, sounds related but doesn’t make sense since i do an update)).

thoughts on where I can look or what I could try next?

It’s not there. There is no nsight for arm currently. It seems you can install the cuda toolkit on an intel machine and do dev there and then cross compile for arm. I tried following the instructions on Ubuntu 14.04 for setting up apt-get to pull in arm libraries for development, but I get:

Err http://archive.ubuntu.com trusty/main armhf Packages
404 Not Found [IP: 80]

When I run sudo apt-get update. Seems something has changed since those instructions were put together. I also see where we should be able to develop on the intel machine and build/run on the arm board, so long as both machines have git.


I was only able to install CUDA 6.5 on Ubuntu 14.04, so I don’t know how well that plays with the CUDA 6.0 install on the jetson. I have not yet tried to build/run any of the sample projects remotely.

I do see eclipse 3.8 available thru apt-get on the jetson. The copy of nsight I have is also based on eclipse 3.8. It may then be possible to copy the right plugin jars and other resources over to the arm board and get nsight to work that way.

It’s a bit of a letdown that nsight is not available to the jetson. That means it won’t be available on those awesome new chromebooks from Acer/HP either. If nvidia would make an install site url available, it would be an easy install via eclipse assuming they didn’t build any native dependencies into nsight.

Alternately, it would be really nice if they would make the plugin source available so we could get a build of it put together running on the latest version of eclipse. 3.8 is like three years old now. I am going to see if I can decompile the version I have and turn that into a build for 4.4. I need to figure out how to build eclipse 4.4 on arm first though :)

I do appreciate the feedback, at least I can know that i wasn’t missing something blatantly obvious. So I tried to go the eclipse 3.8 route as well when I couldn’t think of any other options but 3.8 keeps crashing on me on start up. I haven’t tried chasing that problem yet, tired of trying to just “get started”. So I punted and will ssh into it from my beagle bone, at least I can explore learning CUDA and whether or not I get great gains from it. Maybe I’ll explore cross compiling on the Beagle bone if I get motivated, I just thought debugging/profiling/etc would be easier if I could go native versus remote (hopefully that is a wrong assumption). Thanks again Ramsey for the insight …