Error with nveglglessink : cuGraphicsGLRegisterBuffer failed with error(304) gst_eglglessink_cuda_init texture = 1

Here my setup :

• Hardware Platform (Jetson / GPU) : Geforce GTX 1060 mobile
• DeepStream Version : 6.1
• TensorRT Version :
Cuda version : 11.7
• NVIDIA GPU Driver Version (valid for GPU only) : 515.65.01
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
I use a custom version of deepstream-test-3 with python 3.8
The issue :
After reinstalling drivers because i had issues, and i reinstalled cuda tensorrt and Deepstream but now i have a bug i never saw before (I could see this because i did export GST_DEBUG=3 before running):

I reinstall severals times my drivers,cuda, tensorrt and deepstream using different version but nothing work.
Thanks in advance,
Pierre Corbani
PS: I saw this topic having the same issue (i don’t have libGLE and libEGL linked with nvidia) but the solution provided doesn’t work for me. Link : cuGraphicsGLRegisterBuffer failed with error(304) gst_eglglessink_cuda_init texture =1

From the description, you used TRT and cuda version not same as

  • CUDA 11.6 Update 1
  • TensorRT
    I see you tried different versions, did you try above version?

Yes i tried but i had the same issue, but i just solved this issue with :
sudo prime-select nvidia
Thanks for your time.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.