ESXi 6.5/M10/Server 2016/XenApp 7.14.1 - Black sidebars when connecting to session

I’m setting up a new POC setup at a customer using the following components:
• VMware ESXi 6.5
• XenApp 7.14.1
• Nvidia Tesla M10
• Windows Server 2016

When connecting from an Igel Linux thinclient towards the Published Desktop we experience the behavior in the attachment. The session is running fine, but we don’t see the entire screen.
This sometimes happens from a Windows client, but a refresh seems to happen after a few seconds and the entire screen becomes visible.

This is happening on lower (1280*1024) and higher resolutions, single and multi-monitor setup.

If we reboot the XenApp server, the first session is successful. Starting from the second session, we experience the issue.
If we use Legacy Graphics Mode instead of the default Thinwire mode, we don’t experience this issue. However, this is not optimal.
If I disable the Microsoft RDS GPO setting "Use the hardware default graphics adapter for all Remote Desktop Services sessions", the issue does not occur. However, this setting is needed for accelerating browsers.

Stack information:
• Hardware
o Dell PowerEdge R730
o Nvidia Tesla M10, M10-8A profiles
• Hypervisor
o GRID version 4.3: 367.106
o ESXi 6.5.0, 5310538
• VM
o GRID version 4.3: 370.12
o GRID version 4.1: 369.71 also tested (because of similar kb:–-corruptions%2Fblack-screen%2Fincorrect-mouse-behaviour-often)
o Windows Server 2016 OS, fully patched
o XenApp 7.14.1
• Client
o Igel UD5-LX-50c
o Firmware tested: & 5.10.240
o Receivers tested: 12.1.8,13.3.2,13.4.2

What other Citrix policies do you have applied?

Nothing special actually:
Computer level:
-UPM Settings
-Custom load (evaluator) settings
User level:
-Disable client drives & disable client printing

-Turn of Fair share CPU
-Do not allow client printers
-Use the hardware default graphics adapter for all RDS sessions

Configure the "Display Memory Limit" policy.

The maximum configurable value is now 4194303. Only for a quick test, just replace the default value with 2194303 (replaced the 4 with a 2). You can fine tune it up or down later if needed.

See if that helps.

Thanks for your feedback.

I already tested with this policy but with lower value than yours. I tested your value, but the problem stays.

We have a Server 2008r2 vm running as well on the same ESXi host, with the same version of the GRID driver and the same Citrix VDA. The 2008r2 machine does not have this issue.

It looks like it’s running out of display memory in your photo …

7.14.1 and 2016 do have some issues at the moment. Have a look on the Citrix forums (

Those Receiver clients are pretty old. 4.8 is current. Give that a go … Also, have you tried a different end point device?

I’d be reluctant to change too much, as you mention is works with a change in the Citrix Policies …

Lastly, just make sure you have the correct GRID driver installed in ESXi and paired in your VM.

I don’t know for sure if the Citrix topic you mentioned is related.

The receiver I was testing is the second latest (13.4) for Linux, as the latest is 13.5. 13.5 is not yet available for Igel-V5.

GRID drivers are the last on both host and VM. Just to make sure I mentioned the drivers in the intro.

I know I’m late to this, but I wanted to say I’m having the exact same issue with the same configuration. The only difference is in my case I’m publishing applications, but the result is the same. The entire application isn’t visible, just the top left corner. Add to it, the amount of content displayed appears to be fixed. So if you connect from a lower resolution screen you see more, but connecting from a 4k display you will see less.

I’ve tried using K1, K2 and M60 GPUs to no avail, and I know there are issues with Server 2016 and “black screens”. But not sure the login is the same issue. It could be, but know that I know that it’s not just me I guess we’ll open a ticket with Citrix and see what they say. Worst case the response is wait for 7.15.

I have the same problem with M10 GPU. Upgraded to VDA 7.15 (XenApp) and Receiver 4.9 (locally on Windows 10) issue still.


I have the same issue with HP ThinClient T730, ThinPro 6-64, Citrix Receiver 13.5. Only after installing Microsoft Hotfix KB4034681 on Server 2012R2 wiht XenApp 7.6.


We have the same issue. Running XenApp 7.14.1 and Server2016. We have a NVidia Gris K2 Card.
Within Server 2012R2 we experiance no problems…
Also tweaked the Display memory size policy. No results either.
Hopefully there will be a solution soon…


There is quite a bit of chat in regards to this over on Citrix forums:

I can confirm it is indeed not fixed in 7.15 for me when using the group policy to engage the hardware GPU. Per that article, there is a private fix available for 7.14.1, but not for 7.15 yet. I will probably inquire with support to see if the fix for 7.15 can at least be tested in non-production to see if the problem goes away.


After speaking with Citrix support going through various tests and log collections, the development team indicated that a hotfix might help my situation. I was able to test the hotfix today and I can confirm that with the hotfix, the black seem-less bars no longer appear. You can reference LC7875, but you will have to open a case with Citrix in order to get the hotfix. I imagine that this will be rolled out in a future public release or hotfix (ie. 7.16/etc.)

The cause of the problem per the closure notification was:

The size that is being used for the display is less than the actual size being set for the session, due to a missing function. LC7875 (Defaults hdx to 1024*768)

I hope this is helpful for anybody else experiencing this problem. My case number was 74064214.