Executing CUDA Samples on Jetson

Hello,
I recently flashed and installed components on my Jetson TX2 with SDK Manager, and I’m still in the process of learning to use it. I tried running some of the CUDA Samples provided, but I get the following error:

CUDA error at …/…/common/inc/helper_cuda.h:775 code=100(cudaErrorNoDevice) “cudaGetDeviceCount(&device_count)”

I tried running the deviceQuery script as well, but again it fails with the following output:

./deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 100
-> no CUDA-capable device is detected
Result = FAIL

Not sure if it’s a problem with my Jetson device not being detected; if it helps I’m able to ssh to the Jetson, which I guess means an active connection exists with my host Linux computer (I’m running Ubuntu 18.04). Any help with this would be appreciated. thanks!

Hi,

Just want to confirm first.

Do you run the command on the TX2 itself?
If yes, would you mind to reflash it and install the components again?
We want to make sure this error is not caused by any broken installation.

Thanks.