Jetson Tx2 Cuda 10.2 Manual Installation


I have been using Cuda 10.0 which is installed manually I’ve got Cuda 10.0 from the Jetpack’s json file which has a url of downloadable cuda-repo-l4t-10-0-local-10.0.326_1.0-1_arm64.deb file. Without using the Jetpack, installed the Cuda with systemd-nspawn container and then flashed the Jetson with this custom rootfs.) I need to install Cuda 10.2 in order to use Cuda encode (which is not present in Cuda 10.0) ‘nvjpeg’ API coming with CUDA 10.0 that we have to use on Jetson boards has only decompression utility. If we can manage to use CUDA 10.2 on Jetson boards then we’ll be able to use compression utility of nvjpeg API.

I found that Cuda 10.2 is available according to this link . I have followed the instructions and while installing there were no problems. But when I run the deviceQuery sample, it gives the following error

cuda-samples/NVIDIA_CUDA-10.2_Samples/1_Utilities/deviceQuery/deviceQuery Starting...

 CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 999
-> unknown error
Result = FAIL

Previous version of Cuda 10.0 were giving the correct results. Installation procedure was almost the same but the only difference is I got Cuda 10.0 from the Jetpack’s json file on the other hand Cuda 10.2 is cuda-repo-ubuntu1804-10-2-local-10.2.107-435.17.01_1.0-1_arm64.deb file which is downloaded from the link I have mentioned in the first paragraph.

I know that Jetpack 4.3 supports Cuda 10.0 but isn’t Cuda on arm supposed to work too? What am I doing wrong?

I am sharing the output of Cuda 10.2 installation if you want to see it cuda_10-2_output.log (120.9 KB)

Thanks in advance.

1 Like

I’m also facing the same problem, does anyone know if Xavier or TX2 supports CUDA 10.2 at the moment?

Same problem here. It’s also kind of funny that there is no nvjpeg compression feature in CUDA 10.0 package. Just for this reason I have to migrate to 10.2. Any help from the NVIDIA team would be great.

1 Like


CUDA 10.2 is currently not supported on Jetpack4.3. It will be supported in future releases

Thank you.

Hello neel_patel,

is a manual installation of CUDA 10.2 still not supported on Jetpack 4.3 [L4T 32.3.1]?

I tried upgrading L4T/Jetpack on my TX2 as described here, but the carrier board definitely doesn’t support a newer L4T version.