Manual installation CUDA 10.2 Jetpack 4.3

Is a manual installation of CUDA 10.2 still not supported on Jetpack 4.3 [L4T 32.3.1]?

I tried upgrading L4T/Jetpack on my TX2 as described here , but the carrier board definitely doesn’t support a newer L4T version.

Thanks for Information.

The supported version of CUDA has a tight dependency on low level system components and you should not mix different CUDA releases on a Jetson and should use only the version made available via JetPack/SDKM. If the version of CUDA which comes with that JetPack is 10.2, then it should work, but otherwise not.

It is very likely that whenever the next CUDA release is supplied that it will not be for R32.3.1, but will instead require going to the next/new release.

I see this on an R32.4.3 (I’m not sure what R32.3.1 has):

# dpkg -l | egrep cuda
ii  cuda-compiler-10-2                         10.2.89-1                                        arm64        CUDA compiler
ii  cuda-core-10-2                             10.2.89-1                                        arm64        CUDA core tools
ii  cuda-cuobjdump-10-2                        10.2.89-1                                        arm64        CUDA cuobjdump
ii  cuda-license-10-2                          10.2.89-1                                        arm64        CUDA licenses
ii  cuda-misc-headers-10-2                     10.2.89-1                                        arm64        CUDA miscellaneous headers
ii  cuda-nvcc-10-2                             10.2.89-1                                        arm64        CUDA nvcc
ii  cuda-nvprune-10-2                          10.2.89-1                                        arm64        CUDA nvprune
ii  nvidia-l4t-cuda                            32.4.4-20201027211332                            arm64        NVIDIA CUDA Package
1 Like

Thank you for clarifying @linuxdev!

For completeness, here the version of CUDA on R32.3.1:

ii  cuda-compiler-10-0                            10.0.326-1                                 arm64
ii  cuda-cuobjdump-10-0                           10.0.326-1                                 arm64
ii  cuda-license-10-0                             10.0.326-1                                 arm64
ii  cuda-libraries-dev-10-0                       10.0.326-1                                 arm64
ii  cuda-misc-headers-10-0                        10.0.326-1                                 arm64
ii  cuda-nvcc-10-0                                10.0.326-1                                 arm64
ii  cuda-nvprune-10-0                             10.0.326-1                                 arm64
ii  nvidia-l4t-cuda                               32.3.1-20191209230245                      arm64