Fail to install CUDA Docker Container Launch for eclipse

Hello I’m using Ubuntu 20.04 on a dell laptop (NVIDIA Quadro P3200 Mobile).
As for the manual I installed CUDA 11, which is advised to be used with eclipse nsight plugins instead of the eclipse nsight installation itself.
As far as I try the installation as for:
https://docs.nvidia.com/cuda/nsightee-plugins-install-guide/index.html
I get an error regarding CUDA Docker Container Launch which prevents it to be installed.

Cannot complete the install because one or more required items could not be found.
Software being installed: CUDA Docker Container Launch 11.3.0.202105040214 (com.nvidia.cuda.docker.feature.feature.group 11.3.0.202105040214)
Missing requirement: Cuda Docker Launch 11.3.0.202105040214 (com.nvidia.cuda.docker.launch 11.3.0.202105040214) requires ‘osgi.bundle; com.spotify.docker.client 0.0.0’ but it could not be found
Cannot satisfy dependency:
From: CUDA Docker Container Launch 11.3.0.202105040214 (com.nvidia.cuda.docker.feature.feature.group 11.3.0.202105040214)
To: org.eclipse.equinox.p2.iu; com.nvidia.cuda.docker.launch [11.3.0.202105040214,11.3.0.202105040214]

Any help would be appreciated.