Fail to login with Omniverse Launcher

I’m using Isaac Sim 2022.2.0 for 2 months. It was good until this Monday since when I could not login.

What it looks like:
In launcher, I click “login”. In browser, I type in password and click “login”. Webpage localhost://33480 jumps out, but there is no sign saying “redirect, continue in launcher” as before. In launcher, a circle rotates forever.


What I tried:

  1. Tried Chrome and get same results;
  2. Checked launcher.log, it says “Waiting for login result…” and seems no bugs are reported.
  3. Run AppImage in terminal, the launcher window shows up, nothing is printed, and AppImage ends, leaving the launcher window open.
    2024-05-14 11-19-54屏幕截图

Please help! I suspect that AppImage or sth is broken, because nothing is shown in terminal.
launcher.log (176.0 KB)

Ok a couple of things right off the bat, in the logs.

  1. You are one version of Launcher behind. You are using 1.9.10. The latest is 1.9.11. Please update.
  2. [error] Failed to start the Launcher API: Error: listen EADDRINUSE: address already in use 127.0.0.1:33480
  3. Your log is full on connection problems. Disconnected, Network changes, local ports changed.

So what happened over the weekend ? New network ? New firewall ? What changed ?

Can you just do a full restart of the computer. Something is blocking Launcher.

Thanks for your thoughtful reply!
This workstation is used by multiple users of our group. TWO Isaac Sim were installed, one used by me only and the other used by others (remained logout for a long time).
Your finding inspires me that perhaps the other Isaac Sim logged in during the weekend and blocked the API!
Since this workstation is currently used by others remotely, I may not be able to restart it. Is there a way I can change the address used by Launcher API from 127.0.0.1:33480 to something else?

This sounds complicated. You have multiple copies of Launcher and multiple copies of Issac Sim ? One per Windows Username ? I would just restart the computer, and update the other version as well.

Yeah that’s really complicated… This ubuntu workstation has 10 users and 2 Issac Sim, I use one Isaac Sim myself and others use the other one.
I think you are right, the problem would be fixed by restarting since the other Isaac Sim process would be killed. Just a small problem that others whose scripts are running will kill me LOL