Getting error while login in omniverse

Hi all while login in omniverse launcher getting this error.

there was another user encountering this exact message earlier. was the Launcher working for you before or is this the first time you tried to log in?

Yes, it was working earlier but from Friday I am getting this error.

could you upload your Launcher log as an attachment? i am not sure if there will be anything relevant that could help pinpoint the issue, assuming it’s not from NVIDIA’s side.

launcher.txt (13.7 KB)

here is the launcher log

did you recently download/install the Launcher 1.9.8? if so, can you try restarting your machine and try to log in again?

i am using this launcher version from 2 nov 2023

it’s odd, the log seems to suggest you are using 1.8.2 and has been trying to download 1.9.8 but is waiting for a restart:

[2023-12-12 06:38:28.274] [info]  Omniverse Launcher 1.8.2 (production)
[2023-12-12 06:38:28.294] [info]  Argv: C:\Users\Madhur_Omniverse\AppData\Local\Programs\omniverse-launcher\NVIDIA Omniverse Launcher.exe
[2023-12-12 06:38:28.294] [info]  Crash dumps directory: C:\Users\Madhur_Omniverse\AppData\Roaming\omniverse-launcher\Crashpad
[2023-12-12 06:38:28.542] [debug] Running "C:\Users\ov-user\AppData\Local\ov\pkg\cache-2023.1.0\System Monitor\omni-system-monitor.exe"
[2023-12-12 06:38:28.572] [debug] Running "C:\Users\ov-user\AppData\Local\ov\pkg\nucleus-workstation-2023.1.0\System Monitor\omni-system-monitor.exe"
[2023-12-12 06:38:28.595] [debug] Reset current installer.
[2023-12-12 06:38:28.625] [info]  Running production web server.
[2023-12-12 06:38:28.639] [info]  HTTP endpoints listening at http://localhost:33480
[2023-12-12 06:38:28.649] [info]  Downloading Launcher 1.9.8...
[2023-12-12 06:38:28.672] [debug] Sharing: true
[2023-12-12 06:38:28.779] [info]  Started the Navigator web server on 0.0.0.0:34080.
[2023-12-12 06:38:29.124] [info]  Launcher 1.9.8 is downloaded and ready to be installed after restart.
[2023-12-12 06:38:30.304] [info]  Registered omniverse-launcher for Windows.
[2023-12-12 06:38:30.305] [info]  Registered omniverse for Windows.
[2023-12-12 06:38:42.991] [info]  Login URL opened.
[2023-12-12 06:38:43.060] [info]  Waiting for login result...
[2023-12-12 06:38:45.561] [info]  WEB /login-result?error_description=Authorization+flow+not+allowed&error=invalid_request

can you check the version of your OV Launcher (you could check via installed apps) and see which version you currently have installed?

i see. have you tried using a different browser to log in?

Yes, I have tried.

was there any hardware/network changes recently? does the same message show up when you go to http://localhost:33480 in your browser?

can you also try http://localhost:3080/ in your browser to see if all the services are showing up as ‘running’ under the Apps tab?

Yaaa, it’s running.

i’ll request this thread to be moved to Launcher and maybe the mods/devs there can provide some additional insight. the other user i mentioned is on Linux so it might not be an isolated incident. i am still quite curious about the log report of the an older version.

1 Like

Hi @Simplychenable
Now we are facing the same issue in ubuntu. Please tell us how we can resolve it.

This error is ALWAYS because of an older Launcher. So every attempt must be made to fully upgrade the Launcher. The latest version is 1.9.10. If you cannot get that version to update automatically, you can try to unistall and re-install the latest version manually. If that fails then I would advise you to use the CLEAN UP TOOL Launcher Cleanup Tool — Omniverse Utilities latest documentation