Omniverse Launcher stuck at login In Ubuntu

Since last friday I encounter a problem with the Omniverse Launcher in ubuntu Ubuntu 22.04.1 LTS.
Usually I connect to my account via firefox and then directly into omniverse it continue, but this time It keep loading, even after 1 hour nothing changed.

What I tried :

  • Download the latest Omniverse launcher
  • Used launcher-cleanup
  • Tried with 2 different wifi
  • Reboot computer many time
  • Tried with different browser (Firefox, Brave)

Is there any reason for that ?
Thank you very much.


1 Like

I am having the same problem. Also tried on Chrome but no luck…

this worked for me (Could NOT login the omniverse launcher), but feels like the wrong way to solve this problem.

After putting the missing file in autostart, I have a new error showing :

> (node:31077) UnhandledPromiseRejectionWarning: Error: ENOENT: no such file or directory, access '/home/veronique/.nvidia-omniverse/config/auth.toml'

Did a research (grep) but couldn’t find the file.
Where can I get back this file or how can I uninstall Omniverse, I have difficulty about all these thing in ubuntu …

Did you solve? I’m having the same issue

No haven’t but I just got a confirmation on from a dev in the discord, they’ll try to fix on the next update.

Thanks for reaching out!

Our team is aware of this issue and is working on having it fixed by the next release. In the meantime, try this workaround, enable Launch on Login option from the Launcher tray icon, then restart the application.

Please let us know if you run into any other further issues.


Still not fix and because I am on Ubuntu I don’t have this option showed to me. It bring me directly to this menu


I am still facing the same issue. Any Workaround for this ?

1 Like

Want to bump this request as well.

Maybe someone can suggest a linux procedure to cleanup the environment?
Just so to try a fresh start.

EDIT: solved with:

cd ~
find -name  "*omni*" exec rm -r {} \;

which deletes a bunch of stuff created by omniverse, so to “start fresh”.

Thank you!

1 Like

For me it didn’t work sadly … Still loading on the log in menu.
If anyone have another suggestion please put a comment.

Same problem for me … Any solution ?

1 Like

I as well am unable to log in in the console this message pops up after trying to log in.

08:42:13.925 › (node:16831) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag –unhandled-rejections=strict(see (rejection id: 5) 08:47:19.053 › Login cancelled.

1 Like

Hi, exactly the same problem here, any solution ?

We have a solution for this ready. It needs testing and releasing in the next version of Launcher. Very sorry for the inconvenience

Umm… any confirmed date for that release? I have the same issue and it’s quite a poor UX. Seems kinda weird that I have to sign into my browser to authenticate with an app. It’s no longer the 2010’s anymore where everyone just uses Chrome. Chrome these days is bloated, lacks features, and is full of spyware! I really hope you guys are considering breaking your Chrome habit!

1 Like

Hopefully in the next two weeks !

I just wanna debug my PhysX, man :(
How long is in the next two weeks?

it doesn’t seem to make a difference if launch on startup is enabled or not. if I create the autostart file just so it can find it, it still brings me back to the email entry field.

Also, I don’t think it is a browser issue, I can see from the launcher log that it receives the login result back from the nvidia auth site.