Omniverse Launcher stuck at login In Ubuntu

Tried this on a fresh linux machine 20.04.6 LTS (Focal Fossa) and it unfortunately does not work.

Am I understanding this correctly that 20.04 and 22.04 users have been unable to login since August 1st?

I just downloaded the launcher from the official site with the issue still present. Tested with 20.04.6 LTS (Focal Fossa).

1 Like

Yes our apologies. We have a new launcher scheduled for release hopefully early next week which should fix this login issue.

1 Like

Is there an update? A workaround to use in the meantime?

1 Like

I also had this issue. The only way to solve this for me was to use the Nvidia clean up tool and reinstall the launcher afterwards.

We are happy to announce that Launcher 1.9.8 has been released to production !!

2 Likes

I had the same problem, but I fixed it by downloading the new launcher. Thank you.

Great !!

Installed the latest Launcher, still facing the same issue! Any fixes?

1 Like

Still having the same issue with 20.04 Ubuntu and the new launcher.

I now have fixed it by using Google Chrome instead of Firefox as main Browser. Seems like Omniverse can’t use Firefox for some reason. In the past the browser worked fine for me, so idk exactly what the reason is.

2 Likes

Great

Patch didn’t work for me, I had to get Firefox for it to start up, but it looks like OmniPVD physics debugger is not available for Linux. Very disappointed…

“OmniPVD physics debugger is not available for Linux” - I will verify and get back to you

OmniPVD should be available in Linux as we use it daily in development, but could be a public packaging issue. Would you mind :
going into Window->Extensions
and in the window that appears to write pvd, like in the screenshot
and tell me what appears? (if you don’t have a connection to the extension registry that could be the issue)
window_extensions

Sorry, I was led to believe I had to get Omniverse Create to use PVD. Omniverse Code installs fine. Thank you for your help.

2 Likes

Great !

I uninstall everything and change the browser from Firefox to Google Chrome and then it worked.
But still on Firefox it’s not working.

I am glad it works in Chrome. I would avoid using FF at this time.

Setting Chrome as default help me go to next step in login phase: i managed to enter my password.
Then it hangs fovever without login :-(

in the background, i see these:
10:09:19.698 › (node:1182004) UnhandledPromiseRejectionWarning: Error: ENOENT: no such file or directory, access ‘/home/XXX/.nvidia-omniverse/config/auth.toml’
10:09:19.699 › (node:1182004) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag --unhandled-rejections=strict (see Command-line API | Node.js v21.2.0 Documentation). (rejection id: 7)
10:09:23.103 › Can’t access the /home/XXX/.nvidia-omniverse/config/privacy.toml file: ENOENT: no such file or directory, access ‘/home/XXX/.nvidia-omniverse/config/privacy.toml’

Any ideas?