Omniverse Launcher stuck at login In Ubuntu

uploading the Launcher log might provide additional context. are you using the latest Launcher version (1.9.8)?

I don’t know which version actually. I downloaded it again to be sure.
[edit: it’s 1.9.8 has written below ;-)]

Here are the logs:
10:19:20.639 › Omniverse Launcher 1.9.8 (production)
10:19:20.646 › Argv: /tmp/.mount_omnivemkukdi/omniverse-launcher --help
10:19:20.646 › Crash dumps directory: /home/xxx/.config/omniverse-launcher/Crashpad
10:19:20.649 › Start polling Launcher updates.
10:19:20.756 › Reset current installer.
10:19:20.761 › Running production web server.
10:19:20.765 › HTTP endpoints listening at http://localhost:33480
10:19:20.765 › HTTP endpoints listening at http://127.0.0.1:33480
10:19:20.768 › Sharing: false
10:19:20.877 › Started the Navigator web server on 127.0.0.1:34080.
[1183320:1201/101921.566108:ERROR:object_proxy.cc(623)] Failed to call method: org.freedesktop.DBus.StartServiceByName: object_path= /org/freedesktop/DBus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[1183377:1201/101931.154978:ERROR:angle_platform_impl.cc(43)] Display.cpp:1019 (initialize): ANGLE Display::initialize error 12289: Invalid visual ID requested.
ERR: Display.cpp:1019 (initialize): ANGLE Display::initialize error 12289: Invalid visual ID requested.
[1183377:1201/101931.158380:ERROR:gl_display.cc(504)] EGL Driver message (Critical) eglInitialize: Invalid visual ID requested.
[1183377:1201/101931.158473:ERROR:gl_display.cc(793)] eglInitialize OpenGL failed with error EGL_NOT_INITIALIZED, trying next display type
[1183377:1201/101931.163674:ERROR:angle_platform_impl.cc(43)] Display.cpp:1019 (initialize): ANGLE Display::initialize error 12289: Invalid visual ID requested.
ERR: Display.cpp:1019 (initialize): ANGLE Display::initialize error 12289: Invalid visual ID requested.
[1183377:1201/101931.163779:ERROR:gl_display.cc(504)] EGL Driver message (Critical) eglInitialize: Invalid visual ID requested.
[1183377:1201/101931.163855:ERROR:gl_display.cc(793)] eglInitialize OpenGLES failed with error EGL_NOT_INITIALIZED
[1183377:1201/101931.163944:ERROR:gl_display.cc(819)] Initialization of all EGL display types failed.
[1183377:1201/101931.164023:ERROR:gl_ozone_egl.cc(26)] GLDisplayEGL::Initialize failed.
[1183377:1201/101933.348337:ERROR:angle_platform_impl.cc(43)] Display.cpp:1019 (initialize): ANGLE Display::initialize error 12289: Invalid visual ID requested.
ERR: Display.cpp:1019 (initialize): ANGLE Display::initialize error 12289: Invalid visual ID requested.
[1183377:1201/101933.348513:ERROR:gl_display.cc(504)] EGL Driver message (Critical) eglInitialize: Invalid visual ID requested.
[1183441:1201/101945.861044:ERROR:angle_platform_impl.cc(43)] RendererVk.cpp:157 (VerifyExtensionsPresent): Extension not supported: VK_KHR_surface
ERR: RendererVk.cpp:157 (VerifyExtensionsPresent): Extension not supported: VK_KHR_surface
[1183441:1201/101945.861219:ERROR:angle_platform_impl.cc(43)] RendererVk.cpp:157 (VerifyExtensionsPresent): Extension not supported: VK_KHR_xcb_surface
ERR: RendererVk.cpp:157 (VerifyExtensionsPresent): Extension not supported: VK_KHR_xcb_surface
[1183441:1201/101945.861332:ERROR:angle_platform_impl.cc(43)] Display.cpp:1019 (initialize): ANGLE Display::initialize error 0: Internal Vulkan error (-7): A requested extension is not supported, in …/…/third_party/angle/src/libANGLE/renderer/vulkan/RendererVk.cpp, enableInstanceExtensions:1639.
ERR: Display.cpp:1019 (initialize): ANGLE Display::initialize error 0: Internal Vulkan error (-7): A requested extension is not supported, in …/…/third_party/angle/src/libANGLE/renderer/vulkan/RendererVk.cpp, enableInstanceExtensions:1639.
[1183441:1201/101945.861434:ERROR:gl_display.cc(504)] EGL Driver message (Critical) eglInitialize: Internal Vulkan error (-7): A requested extension is not supported, in …/…/third_party/angle/src/libANGLE/renderer/vulkan/RendererVk.cpp, enableInstanceExtensions:1639.
[1183441:1201/101945.861507:ERROR:gl_display.cc(793)] eglInitialize SwANGLE failed with error EGL_NOT_INITIALIZED
[1183441:1201/101945.861599:ERROR:gl_display.cc(819)] Initialization of all EGL display types failed.
[1183441:1201/101945.861675:ERROR:gl_ozone_egl.cc(26)] GLDisplayEGL::Initialize failed.
[1183441:1201/101950.073573:ERROR:angle_platform_impl.cc(43)] RendererVk.cpp:157 (VerifyExtensionsPresent): Extension not supported: VK_KHR_surface
ERR: RendererVk.cpp:157 (VerifyExtensionsPresent): Extension not supported: VK_KHR_surface
[1183441:1201/101950.073735:ERROR:angle_platform_impl.cc(43)] RendererVk.cpp:157 (VerifyExtensionsPresent): Extension not supported: VK_KHR_xcb_surface
ERR: RendererVk.cpp:157 (VerifyExtensionsPresent): Extension not supported: VK_KHR_xcb_surface
[1183441:1201/101950.073855:ERROR:angle_platform_impl.cc(43)] Display.cpp:1019 (initialize): ANGLE Display::initialize error 0: Internal Vulkan error (-7): A requested extension is not supported, in …/…/third_party/angle/src/libANGLE/renderer/vulkan/RendererVk.cpp, enableInstanceExtensions:1639.
ERR: Display.cpp:1019 (initialize): ANGLE Display::initialize error 0: Internal Vulkan error (-7): A requested extension is not supported, in …/…/third_party/angle/src/libANGLE/renderer/vulkan/RendererVk.cpp, enableInstanceExtensions:1639.
[1183441:1201/101950.073965:ERROR:gl_display.cc(504)] EGL Driver message (Critical) eglInitialize: Internal Vulkan error (-7): A requested extension is not supported, in …/…/third_party/angle/src/libANGLE/renderer/vulkan/RendererVk.cpp, enableInstanceExtensions:1639.
[1183441:1201/101950.074041:ERROR:gl_display.cc(793)] eglInitialize SwANGLE failed with error EGL_NOT_INITIALIZED
[1183441:1201/101950.074115:ERROR:gl_display.cc(819)] Initialization of all EGL display types failed.
[1183441:1201/101950.074184:ERROR:gl_ozone_egl.cc(26)] GLDisplayEGL::Initialize failed.
[1183441:1201/101950.078291:ERROR:viz_main_impl.cc(186)] Exiting GPU process due to errors during initialization
10:19:50.283 › Saving omniverse-launcher.desktop file to /tmp/omniverse-launcher-jVt2Gk…
10:19:50.283 ›
[Desktop Entry]
Name=omniverse-launcher
Exec=“/local/omniverse-launcher-linux.AppImage” --help %u
Type=Application
Terminal=false
MimeType=x-scheme-handler/omniverse-launcher

10:19:50.477 › Saving omniverse.desktop file to /tmp/omniverse-launcher-9aGO1i…
10:19:50.478 ›
[Desktop Entry]
Name=omniverse-launcher
Exec=“/local/omniverse-launcher-linux.AppImage” --help %u
Type=Application
Terminal=false
MimeType=x-scheme-handler/omniverse

10:19:50.627 › Initialized.


I manage to log after entering my email+pwd (see pics)

But on the launcher side, its stays like this:
image

and another empty chrome window opens.

Could this be related to the fact I’m not physically connected to the server but via ssh tunnelling?

[Edit:
Apparently not. I tried directly on the server double clicking on the launcher.
It does not even open chrome to login and stays on the omniverse login page :-(

Any workaround please?
Is it at all possible with the new launchers???
]

You mentioned server ? What server ? Are you Enterprise ? This ideally needs to be all local.

It says that your OPENGL is failing. That is because you are trying to run this on a server without proper GPU acceleration passthrough. A lot of remote or vmware does not support remote GPU acceleration. Therefore the Launcher, being a GPU accelerated app cannot start. Can you not install this on your local machine ? If you are using a server you need to make sure you can access gpu accelerated apps.

No it’s actually a proper machine that I use remotely.

For some obscure reason, after tones of trials omniverse finally launched properly.
Cross fingers it continues like that.

Thx.

So its a remote workstation ? And what remote software are you using to access it ?

ssh / moba xterm or Teamviewer.

So its working ok now ?

Kind of yes sorry for the delay.
At least, the installation could get started.

The login issue was also resolved for me by switching from firefox to chrome! Hope this helps someone

1 Like

Great, glad to hear. Yes please do not use FireFox

1 Like

Hello, @Richard3D

I’m running into this issue as well. I am SSH’ing into a physical machine remotely using X server. I manage to successfully login and everything but the loading gets stuck at the login screen as mentioned above. Any ideas how to get this to work? There’s also all these errors which I can’t seem to fix either (missing auth.toml, etc…)

launcher.log (181.7 KB)

Just to clarify a few things.

  1. You can or cannot login to Launcher ?
  2. If not, what is the error, or what happens
  3. If yes, what do you see ? Do you see your apps listed ?

It could be several things.
Firstly does “X Server” support gpu acceleration ? I searched for it and could not find an answer either way.
Second, are you sure you are able to authenticate correctly ?
Third, do you have a physical monitor attached to the remote machine ? You need that.

Here is what I would suggest. Go to the physical machine (if possible) and try to login and and launch, there locally first. See if that works.

You could also try basic “remote desktop”.

Is it windows or linux ?

Finally it could be an issue with your FIREWALL. You are getting hard refusal to your “auth.toml” file.

I happened to have the same problem and searched for my own post. Which didn’t solved the problem.
Agree on not using Firefox, in my case I used Edge which was also fine.

@reyemai so are you ok now or not ?

@Richard3D Yes, as mentioned, my solution was to not use Firefox.
Which I mean, Firefox is the default and only browser shipped with Ubuntu fresh install. Not even Chromium is shipped together.
So please consider suggesting one of the following options:

  • remove compulsory login for basic application (Isaac Sim, Composer, Code)
  • fix the JS running in the login page
  • run the login page in the launcher integrated browser
  • add a list of compatible browsers as an Omniverse Launcher requirement.

Thank you!

What I don’t understand is why you keep getting prompted for repeat logins. I only have to login very rarely. Once a month at most. Are you constantly turning off your machine ? Are you logging out ?

There is no “compusulary login requirements” for apps. I never have to login for apps. Is this on a corporate network ? You are talking about logging into Nucleus ? Once your launcher is logged in, there should be no logins required ANYWHERE unless you are being signed out of Nucleus or you need to access a restricted drive.