Omniverse Launcher login problem on Linux Ubuntu 20.04

I had a serious trouble logging in the Omniverse Launcher on Kubuntu 20.04 LTS. I have all browsers (Firefox, Chromium) provided from snap so that they are sandboxed and contain latest security fixes. The login opens a default browser by xdg and of course, not any one of them could log in because they are making HTTP request to localhost to notify omniverse launcher after successfully entering user credentials. As a workaround I had to install Microsoft Edge for Linux and make it temporarily default browser and also clean all Omniverse Launcher configuration. After several attempts without success it finally logged in. Seems that Edge has less strict security, or there might have been a glitch with Omniverse.

Your developers should fix omniverse launcher on Linux so that it uses some dumbest looking login form that actually works, as Linux people don’t care about how it looks but about it working. Alternatively make it so the security token can be copy pasted to Omniverse Launcher directly, as sending JSON request on localhost from nvidia page is not usually possible as most browsers like Firefox or Chrome block it, and it is only a matter of time before Edge does the same…

So temporary workaround is to use Microsoft Edge for Linux, but remember that workaround is not solution!

I have the exact same problem on Linux Ubuntu 20.04
Neither Firefox, Microsoft Edge nor Chrome are working for me however.

Console output after attempted login:

11:38:19.697 › Login URL opened.
11:38:19.699 › Waiting for login result…
11:39:28.393 › WEB /login-result?ui_locales=en&code=YE21MRuoHcoWc2kl4b25dE6JF49R6tDdzHAQHZ_imKtRnRUig_RDVAahXUhaQRvCYybF96bDj4yG0hFaWm5IQQ
11:39:31.767 › (node:25743) UnhandledPromiseRejectionWarning: Error: ENOENT: no such file or directory, unlink ‘/home/user/.config/autostart/nvidia-omniverse-launcher.desktop’
11:39:31.767 › (node:25743) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag --unhandled-rejections=strict (see Command-line API | Node.js v20.5.0 Documentation). (rejection id: 2)

EDIT: I further investigated the issue. There was a new Omniverse launcher release in July 2023
I transferred an old appImage from another workstation and that one worked.
Once logged in the current appImage was also able to start the omniverse launcher, even though the errors are still occuring in the console.

I also had the same issue after installing the new launcher. I was able to solve it by toggling “Launch on Login” option. This options adds or removes the “/home/user/.config/autostart/nvidia-omniverse-launcher.desktop” file.
We can find it when you right click on Omniverse logo on the top bar.

I had the same issue on a different Linux distribution and got stuck for quite some time. I thought it is a browser issue and tried switching around default browsers and eventually gave up on it. Revisited it with the same results. The solution for me was not to open it from the terminal!

Change permissions on the app-image to make it executable → open your file explorer and double click!. It will open the familiar login but return from the browser window to proceed compared to getting stuck.
Good luck!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.