Failed to login(stuck after logging in web browser)

I’m using the linux version of omniverse launcher(appimage), everything goes well before today, I have a problem of logging in, after I login in my web browser(the web page notice me that I can continue in launcher), the launcher stuck in login page like in the following screenshot:

the log here:

15:22:15.626 › Login URL opened.
15:22:15.629 › Waiting for login result...
15:22:28.604 › WEB /login-result?ui_locales=en&code=<some_code>
15:22:28.765 › WEB /favicon.ico
15:22:29.617 › (node:18242) UnhandledPromiseRejectionWarning: Error: ENOENT: no such file or directory, unlink '/home/stardust/.config/autostart/nvidia-omniverse-launcher.desktop'
15:22:29.618 › (node:18242) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see (rejection id: 2)

I used to use the isaac sim and composer with this launcher, it works fine

------------------------- EDIT -----------------------
found this post Omniverse launcher can not login - #2 by WendyGram
don’t know if it is the reason why I can’t login? but how to explain the login process works fine before?

1 Like

I am having the same problem, I am writing here to avoid having a duplicate topic.
Until two days ago everything was running fine, but today it gets stuck at the login page. @Te77iiiii_Ho if you managed to solve the issue, can you please tell me how?

I have the same problem since July 18 2023

Hi, @michele.angelini2 @charbel-boumaroun . sry I still can not login the omniverse-launcher, but if you want to use the specific app, you can directly launch it from command line. e.g. for composer(creator) just run <home_dir>/.local/share/ov/pkg/create-2022.3.3/

but for isaac sim, when I ran I can’t find ros examples from it, which is differ from launching isaac sim from omniverse launcher

I am also having the same issue since the 19th of July. After I confirm the login in the browser, the launcher loads forever.
Would maybe deleting the local cache for omniverse solve this?

I solved the issue by looking for the “nvidia-omniverse-launcher.desktop” file and copying it into the directory mentioned by the error (“/home/user/.config/autostart/”).
I hope this helps.


Hi, did anyone solve the problem? I don’t get an error message but I can’t log in on Omniverse Launcher either. Unfortunately, @michele.angelini2 's hint didn’t help for me.

This worked for me too, thank you!

I used find / -name '*.desktop' | grep -i "omniverse-launcher.desktop" to find the .desktop file (In my case it was in the /tmp directory: “/tmp/.mount_omniveHeXU3G”) and copied it to “/home/USER/.config/autostart/”

1 Like

works for me~!
so weird that if missing the .desktop file is the issue, why I can login before…

could you share some logs? @michele.angelini2 's method works for me. I launch the omniverse launcher through the AppImage file in command line, and I can check the log in terminal, if your log isn’t the same with mine, I think it might be a another issue.

apparently, another file is missing, but I don’t know where to take it from. Do you have a privacy.toml / auth.toml at /home/user/.nvidia-omniverse/config?
the logs

@sina.heidemann Yes, I have those two files, but the auth.toml is empty, and privacy.toml is like this:

performance = true
personalization = true
usage = true
userId = "<my_user_id>"
idpId = "<my_idpId>"
idpName = "NVIDIA-J"
extraDiagnosticDataOptIn = ""

  version = "2.0"

  version = "1.1"

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.