Omniverse Launcher Error

Gud Mrng Team,

I am facing issues with Omniverse Launcher. I have given details of my environment and the issue that I am facing. Any help would be highly appreciated.


AWS EC2 g4dn.4xlarge

Windows 2012

Behind company proxy server

Chrome as default browser

Tried below steps

  1. Downloaded and installed Omniverse Beta
  2. Opened “Omniverse Launcher” as “Admin”
  3. Took me to nvidia login page
  4. Gave my credentials and web login pass thru
  5. Omniverse launcher was showing progress bar in login
  6. But then finally landed on the same login screen without showing any error - showing user text box with my account and login button. Going in cyclic loop.


Checked the Omniverse logs and noticed these errors

“Can’t access the c:\users\….nvidia-omniverse\config\omniverse.toml file: ENOENT: no such file or directory, access


I see same error for other files aswell





And below error aswell

Fetcherror: request to failed, reason: Connect etimeout

But if I try the url from browser (chrome) it loads just fine

FYI I was launching the Launcher as “Administrator” only


Can you try adding your proxy server IP during the startup of Launcher:

In windows we have two shortcuts, one in the desktop and the other one in the apps, it is safe to set in both

  • For Desktop Shortcut: right click on the Omniverse launcher desktop shortcut → Click properties → Open shortcut tab → in the target add --proxy-server= at the end after a space

  • For Apps Shortcut: type Omniverse launcher in the search bar → right click and select open file location → Right click on Omniverse Launcher Shortcut → Click properties → Open shortcut tab → in the target add --proxy-server= at the end after a space

Thank you @mirice Finally got it working.

But here is the catch - may be it helps someone

  1. When I downloaded Omniverse beta it downloaded a exe for me named “Omniverse-launcher-win.exe”
  2. I created a shortcut for it and added the proxy entry that @mirice recommended
  3. The exe installed another exe named “Nvidia Omniverse Launcher.exe” with a shortcut in desktop and auto launched itself with login screen
  4. I logged in and the setup failed with “proxy or firewall” issue. [since this exe was auto launched it wud not have had proxy entry]
  5. So I closed the launcher and added the proxy entry and opened the exe again
  6. It failed again with same error.

Then after little digging I noticed that - though I closed the Nvidia launcher during first auto launch, it was still hanging around in process. Under windows task manager I was able to see 3 process of “Nvidia Omniverse Launcher”. If I killed the first process it was auto opening again. Same for the second process aswell. Finally I went to the bottom of the task manager and killed the last and 3rd process that was running - it auto killed the other two aswell.

After I was sure there were no process running, I tried opening the exe again and it worked.

So, I guess the first launch kept Nvidia launcher process hanging and that didn’t take the new proxy setting I added and when started the second time. It was continuing from we’re it left and showed the same error even though this time I had the proxy setting added.

Hope it helps someone. Thank you
Thanks @mirice for your support.

1 Like

@magesh.k - Thank for for this feed back. Will incorporate your learnings in Omniverse documentation. Thanks…

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.