Fail to run deepstream5.0 python sample app using anaconda python environment

Please provide complete information as applicable to your setup.

• Hardware Platform: GPU
• DeepStream Version: 5.0
• JetPack Version: None
• TensorRT Version: 7.0.0.11
• NVIDIA GPU Driver Version: 440.33.01

• CUDA Version: 10.2
• CUDNN Version: 7.6.5
• Ubuntu: 18.04

Hi, please find my setup above. I am able to run the deepstream python sample app on my dGPU setup and see the popup window showing the inference results video. The command I use is shown as below:
python3 deepstream_test_1.py /opt/nvidia/deepstream/deepstream/samples/streams/sample_720p.h264
However, I cannot run this sample app in my anaconda python environment. Since I am in conda environment, I use the following command:
python deepstream_test_1.py /opt/nvidia/deepstream/deepstream/samples/streams/sample_720p.h264
Then I got:

I have tried to copy the pyds.so file under the /opt/nvidia/deepstream/deepstream/sources/python/bindings/x86_64 to /my-path-to-anaconda3/lib/python3.6/site-packages/ and modify the deepstream_test_1.py to make sure import pyds from the anaconda environment.
Then I got:

I have also tried to copy the libnvdsgst_inferserver.so, libgstcoreelements.so, libnvdsgst_osd.so to /my-path-to-anaconda3/lib/python3.6/site-packages/, but it only helps to get rid of the first GStreamer WARNING. The rest two warnings remains.

Could you help me resolve this? Thanks in advance.

You do not need to copy the libnvdsgst_inferserver.so, libgstcoreelements.so, libnvdsgst_osd.so to /my-path-to-anaconda3/lib/python3.6/site-packages/, which GPU you are using? deepstream required nvidia GPU display card for output using type 2 eglglessink, if you use Tesla series card, you could follow this wiki to setup virtual display, https://elinux.org/Deepstream/FAQ, or you could change python code sink from nveglglessink to fakesink.
#sink = Gst.ElementFactory.make(“nveglglessink”, “nvvideo-renderer”)
sink = Gst.ElementFactory.make(“fakesink”, “nvvideo-renderer”)
another option is you could use deepstream-test1-rtsp-out/ for rtsp streaming, then you could view the output through player vlc.

I am using RTX2080Ti.
And my problem is that I can run the test in native python3 environment but I cannot run the test in anaconda3 python3 environment. I am not sure if display is the cause of that.

Oh, missed you running from conda environments, so the issue related with conda environments.

Yes, I guess there is something wrong with my conda environment. The conda cannot find the gst or something related. Could you help me resolve this?

I do not have experience of conda, you may need to figure out yourself.
by google search or some other means.

Hi, I meet same problem as you, have you solved the problem already?

Hi,
no I gave up. I just use native environment