Failed building wheel for H5py before tensorflow install

Hi, I am attempting to install tensorflow followed by deeplabcut on my Nvidia- “Jetson Nano 4gb” dev kit. I successfully followed the instructions until I was unable to install h5py.
I followed instructions and workarounds from and other websites that I have detailed in the attachment “attempt_details.txt”

The error message I see is in the attachment “err.txt” is mainly “Failed building wheel for h5py”
And the jetpack version is 4.6 and is detailed in the attachment “jetpack_ver.txt”

attempt_details.txt (1.1 KB)
err.txt (306.9 KB)
jetpack_ver.txt (3.4 KB)

I have checked both the posts on this website and both are not helpful in my case

  1. error-failed-building-wheel-for-h5py/247623 (resolution: reflash)
    => I have tried reflashing multiple times but has not helped
  2. failed-building-wheel-for-h5py-on-jetpack-4-6-1-on-xavier-nx/213890 (resolution: use jetpack 5.x)
    => Since Im using “Jetson Nano 4GB” (and not Xavier), upgrading to Jetson pack 5.x is not possible

Any help would be greatly appreciated!


Could you check if the below topic can help with your use case?


After updating h5py I’m still getting an error.
I had to update numpy and a few other dependencies but the issue was still not solved.
With this method, I’ll have to even update the Ubuntu OS so it’s not a viable solution.
I bought Jetson Nano from the nvidia store and have just stuck to instructions on the nvidia website.

Is there an alternate way to resolve this?


Please try the instructions shared in the below topic:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.