Failed to flash pegasus board

Please provide the following info (check/uncheck the boxes after clicking “+ Create Topic”):
Software Version
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.4.1.7402
other

Host Machine Version
native Ubuntu 18.04
other

I followed the video guidance from your website(NVIDIA DRIVE AGX Developer Kit - How to set up - YouTube), but always failed to create drive platform targetfs, it seems the docker issue make it failed

The init setting of pegasus board: DriveWorks 2.2

SDKM_logs_DRIVE_Software_10.0_(rev.2)_Linux_for_DRIVE_AGX_Developer_Kit_2021-03-24_22-06-15.zip (3.5 MB)

The sdkmanager failed logs

My host ubuntu 18.04 with GPU:

Dear @yafei.meng,
May I know, what was the DRIVE SW version on target before flashing DRIVE SW 10?

how could i quickly check my DRIVE SW version? i know the driveworks is 2.2?
which cmd should i run in pegasus to get the DRIVE SW Version?

Dear @yafei.meng ,
ok. Driveworks 2.2 means you already have DRIVE SW 10.0 on target. May I know why you want to flash the target again with DRIVE SW 10.0? Also, could you confirm if apt-get is working on your host without any issue?

Actually, i do not know how to start with pegasus, i just saw the video training for starter.
But in the coming usage, i will flash qnx to it, sometimes have to flash DriveOS to it again. That is why i want to know how to flash everything about the init-setting of pegasus.
And now i am still exploring how to cross-compile for some tensorrt application in my host.

I am trying to solve this issue.

bye the way, why there is no option about QNX os? only linux is available. should i pay extra fee for that in order to use sdkmanager to flash qnx?

Dear @yafei.meng ,
It looks like apt-get is broken on your system which is causing the issue. Could you please fix the issue with sudo apt-get update before flashing the target or check flashing from another host which has no issue with apt-get.

why there is no option about QNX os? only linux is available. should i pay extra fee for that in order to use sdkmanager to flash qnx?

QNX release are not available in nvidia.developer DRIVE SW releases. Could you please contact your NVIDIA representative for access to QNX release?

OK, i got it,

  • I will reinstall the sdk-manager, try to fixed the apt-get issue.

  • I will get QNX os from my company.

Thanks for the quick reply.

1 Like