Failed to install Isaac Lab

When I use this command ./isaaclab.sh -I, I got this error “FileNotFoundError: Could not find the isaac-sim settings file: .vscode/settings.json”. Then when I browse through the files inside the IsaacLab, I found out that “settings.json” file was missing from the beginning during git clone from “git clone GitHub - isaac-sim/IsaacLab: Unified framework for robot learning built on NVIDIA Isaac Sim”. Is there any other solutions? Thanks.
Screenshot 2567-06-07 at 15.16.58

Hi there, the settings.json file is part of the Isaac Sim binaries. Please make sure the set up the symlink correctly to your local Isaac Sim directory: Installation using Isaac Sim Binaries — Isaac Lab documentation.

So I have successfully installed the Isaac Lab, however, when I am trying to verifying the installation, I get this error.

Hi, I met the same issue. I’m wondering if you have solved it? Thanks.

Hello, at the moment, I could not find a solution to the Module not found error “omni.kit”, however if you found a solution please give an update, thank you.

Sure. Are you able to run Issac Lab in any other way? I have tried to run with --headless, it’s running without giving any error. But when I try to use streaming client, it showed unknown error and can’t video stream it.

I have not tried it with --headless yet, however, I was not able to run Isaac Lab in general, even the examples given in the documents.

Hi, @NorthTronV .

Have you tried to create the symbolic link of Isaac sim by Installation using Isaac Sim Binaries — Isaac Lab documentation?

ln -s path_to_isaac_sim _isaac_sim
For example: ln -s /home/nvidia/.local/share/ov/pkg/isaac-sim-4.0.0 _isaac_sim

Yes, that works for me however, the only thing that is preventing me from opening Isaac Lab or its example in the document at all is this: https://forums.developer.nvidia.com/t/unable-to-install-isaac-sim-package-for-isaac-lab/295628?u=northtronv