Error occurred during installation of Isaac Sim: Command failed: "/home/dhruvm/.local/share/ov/pkg/isaac_sim-2022.1.0/"

Hello, I’m getting the following error while installing ISAAC SIm. I’m installing it via the omniverse launcher in my local pc
Error occurred during installation of Isaac Sim: Command failed: “/home/dhruvm/.local/share/ov/pkg/isaac_sim-2022.1.0/”
X Error of failed request: GLXBadFBConfig
Major opcode of failed request: 152 (GLX)
Minor opcode of failed request: 0 ()
Serial number of failed request: 194
Current serial number in output stream: 194
2022-06-18 03:05:50 [2,209ms] [Error] [omni.core.ITypeFactory] ITypeFactory must not be destructed post-main. plugins will not be unloaded.
/home/dhruvm/.local/share/ov/pkg/isaac_sim-2022.1.0/ line 17: 4860 Segmentation fault (core dumped) ${SCRIPT_DIR}/

This is my nvidia-smi output
Fri Jun 17 23:04:20 2022
| NVIDIA-SMI 510.73.05 Driver Version: 510.73.05 CUDA Version: 11.6 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
| 0 NVIDIA GeForce … Off | 00000000:01:00.0 Off | N/A |
| N/A 53C P0 N/A / N/A | 9MiB / 4096MiB | 0% Default |
| | | N/A |

| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
| 0 N/A N/A 1052 G /usr/lib/xorg/Xorg 4MiB |
| 0 N/A N/A 1805 G /usr/lib/xorg/Xorg 4MiB |

It seems you don’t have a GPU!

I have an NVIDIA Geforce RTX 3050 Ti

Also, I have a dual boot system. In windows, ISAAC Sim works fine but it does not in Ubuntu (20.04)

I had the same problem when I tried to install the ISAAC SIM on a server through chrome remote desktop.

I solved the problem by reinstalling the GPU driver on the server and installing ISAAC locally.

1 Like

Did you try to change your driver version to the recommended on in the doc?

@dhruvm1 fully exit from the launcher (close it in the taskbar)
then set this environment variable in a new terminal window


and start the launcher in that same terminal, try installing again, does the same error occur?

Yes, still the same error occurs.

What is the output of

glxinfo | grep "OpenGL version"

After using the export command it says this:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 21.2.6

You’re trying to install 2022.1.0. That one is still beta version. I have same problem too. Probably still not compatible with all gpus.
I recommend you to install other versions of Isaac Sim.

Hi, please share the output of nvidia-smi. It looks like you have 4GB or VRAM. We recommend a minimum of 8GB of VRAM to have a good experience.

Were you able to run Isaac Sim, Create and Code on Windows and load Isaac Sim assets on them successfully on Windows?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.