Failed to load the native tensorflow runtime on jetson tx2

I get an error once i go to import tensorflow, after i go to my python2.7, i am not sure on how to proceed on fixing this issue.
Traceback (most recent call last):
File “”, line 1, in
File “/usr/local/lib/python2.7/dist-packages/tensorflow/init.py”, line 22, in
from tensorflow.python import pywrap_tensorflow # pylint: disable=unused-import
File “/usr/local/lib/python2.7/dist-packages/tensorflow/python/init.py”, line 49, in
from tensorflow.python import pywrap_tensorflow
File “/usr/local/lib/python2.7/dist-packages/tensorflow/python/pywrap_tensorflow.py”, line 74, in
raise ImportError(msg)
ImportError: Traceback (most recent call last):
File “/usr/local/lib/python2.7/dist-packages/tensorflow/python/pywrap_tensorflow.py”, line 58, in
from tensorflow.python.pywrap_tensorflow_internal import *
File “/usr/local/lib/python2.7/dist-packages/tensorflow/python/pywrap_tensorflow_internal.py”, line 28, in
_pywrap_tensorflow_internal = swig_import_helper()
File “/usr/local/lib/python2.7/dist-packages/tensorflow/python/pywrap_tensorflow_internal.py”, line 24, in swig_import_helper
_mod = imp.load_module(’_pywrap_tensorflow_internal’, fp, pathname, description)
ImportError: libcublas.so.9.0: cannot open shared object file: No such file or directory

Failed to load the native TensorFlow runtime.

Hi

Have you installed CUDA toolkit on your device?

ImportError: libcublas.so.9.0: cannot open shared object file: No such file or directory

Please noticed that TensorFlow requires CUDA and cuDNN libraries.

If you already installed these packages on your device, please check the package version.
There are some dependency between CUDA drive and libraries.
It’s recommended to use JetPack3.3 and install our official TensorFlow from here:
https://devtalk.nvidia.com/default/topic/1038957/jetson-tx2/tensorflow-for-jetson-tx2-/

Thanks.

I did use Jetpack3.3, which i thought put the CUDA and cuDNN libraries onto the board, and i used the tensorflow from the provided link as well, and i am still getting the same error.

Hi,

Could you check if CUDA is well installed on your device?
It should be located at the ‘/usr/local/cuda’.

Also check if there are cuBLAS libraries installed:

$ ll /usr/local/cuda/lib64/libcublas*

Thanks.

from what i can tell and from that command CUDA and cuBLAS libraries are not on the tx2 for me.

Hi,

Run the command shared in comment#4.
If no cuBLAS file is found, please reflash your device and install the CUDA toolkit from JetPack.

Thanks.

were you able to solve it ?

i am having the same issues…