Fedora black screen on startup but manually startx works

i have a lenovo laptot with a nvidia gtx 1650ti and an integrated amd gpu fedora34 and kde, i use sddm, i installed the nvidia driver and after i set nvidia as primary gpu (option Primarygpu yes) i’m able to use nvidia as gpu but on startup i receive a black screen, if i switch tty and type startx all work fine. i’ve blacklisted nouveau.
nvidia-bug-report.log.gz (1.1 MB)

Have you disabled wayland?

yes i put WaylandEnable=false in sddm.conf file under the [wayland] section.
I’m struggling on it, on startup no errors are shown during boot but at the end of the boot my screen is totally turned off and it activates only if i switch terminal.

Try this: sudo nano /etc/gdm/custom.conf
then, uncomment WaylandEnable=false. That worked for me, I hope it would be useful!

i’m using sddm, in /etc/sddm/ i have sddm dir, sddm.conf.d and sddm.conf file. i also tried with kdm but nothing, i think is a screen problem because if i close my laptop and reopen it i can find sddm to login working. in nvidia x settings i see my screen is PRIME