Random BlackScreen on Boot - Ubuntu 18.04 dual boot with windows 10


My alienware laptop has dualboot with windows. I have no issues running Nvidia card on Windows. However, in Ubuntu, I have random behavior where it sometimes loads fine (no blackscreen) sometimes it doesn’t. I get this blackscreen after I enter my encryption password for my SSD.

Also, Sometimes when I go to recovery terminal. I can run nvidia-smi and see and output. Othertimes it goes to blackscreen right away after I type it and hit enter. Sometimes I also see no processes running.

After about 12 tries, I was able to get a welcome login screen. I’m sure I will run into the same issue after I restart the computer again.

Here is some additional info:

Mon Jun 22 09:07:53 2020
| NVIDIA-SMI 440.59 Driver Version: 440.59 CUDA Version: 10.2 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 GeForce GTX 1070 Off | 00000000:01:00.0 On | N/A |
| N/A 56C P0 41W / N/A | 519MiB / 8114MiB | 3% Default |

| Processes: GPU Memory |
| GPU PID Type Process name Usage |
| 0 1557 G /usr/lib/xorg/Xorg 449MiB |
| 0 3972 G …AAAAAAAAAAAACAAAAAAAAAA= --shared-files 33MiB |

uname -msrp
Linux 4.15.0-106-generic x86_64 x86_64

cat /etc/lsb-release

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

Hello @generix

Thanks for your reply back.

I ran into the issue again. Please find logs attached.

I ran the script multiple times.

It went to blackscreen after I ran the script.


nvidia-bug-report0.log (1.1 MB) nvidia-bug-report1.log (1.1 MB) nvidia-bug-report2.log (1.1 MB)

Actually, I don’t know how you were able to get an output at all.

  • remove ‘nomodeset’ kernel parameter
  • delete /etc/X11/xorg.conf
  • make sure nvidia-prime is installed (sudo apt install nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)

Now the hard part, you’re often getting

NVRM: GPU 0000:01:00.0: GPU has fallen off the bus.

meaning, the gpu is crashing. Please add kernel parameters
pcie_aspm = off intel_idle.max_cstate=1
and reboot.

Where should I add pcie_aspm = off intel_idle.max_cstate=1 ? Filename and locaton please?

Also, the reason why I added nomodeset was because I was getting blackscreen. I have two login screens, one for disk encryption and one for user credentials welcome screen. Is it necessary to remove it?

Is the gpu crashing because it is going bad?

Thank you

replace nomodeset with the parameters, save, then run sudo update-grub

Unfortunately, Replacing the nomodeset parameter didn’t help. I now have to black login screens. The first one where I enter the encryption password and the welcome screen. I can tell that, I can bypass the encryption screen. It changes from dark gray to black after I enter the password and hit enter. I made sure to update grub and initramfs along with everything mentioned. Please let me know if you have any other suggestions.

Please boot to recovery mode and create a new nvidia-bug-report.log. Then run
sudo prime-select intel
and check if you’re getting a login after reboot.


I tested over the last several days. After I rebooted the machine, I didn’t experience the same issue. I always now get the login screen after I enter the encryption password. The screen for the encryption password is black, but this is a much less of an issue in-comparison to the login screen issue.

Thank you. I marked the ticket as resolved.