Firmware install on production module

Is it possible to flash Nano Production (B01) module using P3450-A02 carrier board?
I tried this, and install script said “flashing succesfull”. Is it just empty message or should my board work now?
Im trying to develop custom carrier board for B01 module, but it is in early stage and I need to debug it. Should I be able to connect fresly flashed module with GBE? I mixed up pinout of the ETH jack and my friend told me that he was able to connect with jetson (using two MD pairs) when it was supposed to be with empty eMMC but apparently came with something preinstalled. Is there console output on UART2 (debug) enabled by default? If yes, then with what baud?

hello macck,

it’s not supported. you cannot put B01 module to A02 carrier board.

please access Nano Product Design Guide and check Chapter-11.3 for the details of all three UARTs on Nano.

I tried different approach - grounded VBUS_DET and FORCE_RECOVERY pins,
attached GND D+ D- to USB0 +/- pairs and powered board but SDK manager is unable to detect nano in my carrier board. Im assuming correct power delivery as my friend tested board default software that came with the board (for whatever reason) and was able to mount USB device for example. By developer carrier board production module is discovered in SDK manager right away after powering it on with jumper on force rec pin.

Do i need something else to be able to install firmware onto nano? I thoguht that force recovery would be enough combined with USB0 connection…