Fixing the streaming resolution of Isaam Sim on Websocket

I am trying to run Isaac Sim over the internet using WebSocket on a docker container (either by running the bash file or by running standalone python scripts). Websocket seems to adapt the resolution of the stream depending on my PC resolution and the browser window size. This is an issue for me as the application fonts become too small due to high screen resolution. Therefore, I would like to fix the resolution to a low value. However, I did not manage to do this.

How can fix the resolution?

Note: setting window_width/height values on the config file seems to be ignored while running from standalone files.

    "width": 1280,  # 1280
    "height": 720,  # 720
    "window_width": 1920,  # 1920
    "window_height": 1080,  # 1080
    "headless": True,
    "renderer": "RayTracedLighting",
    "display_options": 3286,  # Set display options to show default grid

Try adding these arguments:
--/app/window/width="1280" --/app/window/height="720"

You can edit this in the omni.isaac.sim.headless.websocket.kit file too.

It does not work. Actually, maybe it does work for a few milliseconds, but it immediately adapts to the monitor resolution/browser size, so I do not see the effect of the width/height settings. Changing other settings (e.g., drawMouse) has an impact.

Is there a setting to disable the automatic scaling/adjustment of the view in websocket?

Any news?

Hi. I’m afraid there is no setting to disable this currently.

Is there a workaround to have bigger icons/fonts using websocket? How is it in WebRTC?