Flash error while installing SDK manager. Could not find a dtb

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.8.1
[V] DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)
DRIVE OS 6.0.4 SDK
other

Target Operating System
[V] Linux
QNX
other

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-300)
DRIVE AGX Orin Developer Kit (940-63710-0010-200)
DRIVE AGX Orin Developer Kit (940-63710-0010-100)
[V] DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)
other

SDK Manager Version
1.9.3.10904
[V] other: 2.1.0.11682

Host Machine Version
[V] native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers
other

I faced the following error. I unboxed the Orin, downloaded the SDK manager, and tried to install Drive OS.

[2024-07-08 15:51:19,254 root DEBUG console_logger.py 17 813268] b’[bootburnTegra-A]: [CopyStorageDtbImage(1393)] : ***** Not found DTB from command line, look for fixed name in standard path *******\r\n’
[2024-07-08 15:51:19,255 root DEBUG console_logger.py 17 813268] b’[bootburnTegra-A]: [CopyStorageDtbImage(1399)] : Kernel DTB not found in CopyStorageDtbImage() \r\n[bootburnTegra-A]: [CopyStorageDtbImage(1408)] : **** Finding BPMP DTB from configuration files \r\n’

Here is the log file.
driveinstaller.log (1.6 MB)

Could you advise me on how to resolve this error?
Best regards,

Dear @sh.roh,
Any reason for using DRIVE OS 6.0.6? If can be upgraded to DRIVE OS 6.0.8.1, Please use docker flashing method Install DRIVE OS 6.0.8.1 for NVIDIA Developer Users | NVIDIA Docs to avoid host system related errors.

Hello @SivaRamaKrishnaNV
Thank you for your advice.
I wanted to use the SDK manager, which supports 6.0.6, not 6.0.8.1. That was the reason.
I thought the other installations were ok except for the flashing, so it seems unrelated to the host system.
Best regards,

Any specific reason to stick to sdkmanager?
Could you share full sdkmanager logs?(~/.nvsdkm/ folder)
you can also flash DRIVE OS 6.0.6 using docker.

Hello @SivaRamaKrishnaNV
I am not sticking to the Sdk manager.
I just wanted to clarify the cause, but it seems not my scope, so I tried to use docker for 6.0.8.1
I successfully flashed it, and created a user account.
But I could not login again after the first login.
The serial port output is very slow and it was stopped to print in the middle of the booting.

The following is the log with sudo minicom -w -D /dev/ttyACM0
Even though it showed “test success” I could not go further since it was stuck.
Could you advise me?

[  OK  ] Started Disk Manager.
[  OK  ] Finished Disable power fea�.|s such as ;1;39mCompanion services for Nvidia Tegra.
[  OK  ] Started Network Name Resolution.
[  OK  ] Reached target Network.
[  OK  ]      Starting containerd container runtime...
[  OK  ] Started NVIDIA MCC Daemon.
         Starting OpenBSD Secure Shell server...
         S] Finished Permit User Sessions.
         Startingted Serial Getty on ttyS2.
[  OK  ] Reached target Login Prompts.
[  OK  ] Stag SSH Host Key regeneration...
[  OK  ];1;39m INFO ] Skipped Check version of 3898 Switch Firmware.
[  OK  ] Started GNOME Displairectory /run/user/110...
[  OK  ] Finished tarted containerd container runtime.
[  OK  ] Started User Manager for UID 110.
[ED25519 SIGN GENERATE/VERIFY test success!
��[  OK  ] Started Session c2 of user gdm.
��         Starting Locale Service...
��CBC ENCRYPT/DECRYPT test success!
.
         Starting Hostname Service...
         Starting Manage, Install and Generate Color Profiles...
e Color Profiles.
GMAC GENERATE/VERIFY test success!
: KEY EXCHANGE test success!
RSA test success!
KEY COPY test success!

I saw the offline in the minicom(I don’t know why the offline happened right after booting.) So I opened another terminal and could login. I will try to test an app and come back to here. Thank you~

Best regards,

Hello @SivaRamaKrishnaNV
Somehow, I could configure the IP address, but when I rebooted the board, I could not. I should’ve set it in the .profile or .bashrc.
I tried to write down the configuration command, but the serial port was very strange. I could not type a command properly, and sometimes, the sentence was broken. I tried to change the baud rates, but it is still a problem.

Is this serial port issue an actual issue, or is this just for me?
Could you advise me on how to use the serial port better?
Best regards,

Dear @sh.roh,
Please check About Minicom | NVIDIA Docs if it helps.

1 Like

Hello @SivaRamaKrishnaNV
I don’t know why but the serial port worked fine.
If I face a similar issue, I will check what you shared.
Thank you for your help.
Best regards,