Drive OS 6.0.6 flash error: **** Error: could not create boot blob ****

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)
DRIVE OS 6.0.4 SDK
other

Target Operating System
Linux
QNX
other

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)
other

SDK Manager Version
1.9.2.10884
other

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers
other

Hi,

I receive an error during flashing of the Drive AGX Orin board with Drive OS 6.0.6.

Target HW: Drive AGX Orin
Platform: p3710
Drive OS: Drive OS 6.0.6
SDK manager: 1.9.2.10889 x86_64
Host PC: Ubuntu 20.04

image

I tried to flash the board in recovery mode. Because only in recovery mode both usb ports are available by the host os (checked with lsusb).

I also tried to fix the flash error how it is described here (which worked at least for the Drive OS 6.0.5)

Please see the detailed log here:
driveinstaller.log (73.7 KB)

Thank you in advance.

Dear @madison_de,
Did you put the board in recovery before try flashing using sdkmanager? If so, please keep the board in normal mode and check flashing with sdkmanager.
Also, the error seems to be different from what noticed in SDK manager flash failed

Could you attach ~/.nvsdkm/ logs and ~/.nvsdkm/sdkm*.log files as well

I have found the error messages in your driveinstaller.log and will discuss this issue with our team.

In the meantime, please refer to the following Install DRIVE OS Linux Docker Containers from NGC | NVIDIA Docs and try to flash with docker container.

Additionally, could you please provide us with some background information about the devkit? Has anyone been able to successfully flash it before?

[2023-05-03 14:00:42,471 root INFO pdk_bind.py 180 28232] Executing bind clean cmd make/bind_partitions -b p3710-10-s05 linux clean
[2023-05-03 14:00:42,488 root DEBUG pdk_bind.py 213 28232] Bind partitions failed !
Traceback (most recent call last):
File “/dvs/git/dirty/git-master_foundation/out/embedded-foundation-generic-release-none/packaging/stage_driveinstaller/driveinstaller/module/pdk_bind.py”, line 185, in pdk_bind
File “/dvs/p4/build/sw/tools/linux/mods/python-3.6.3-glibc-2.5/lib/python3.6/subprocess.py”, line 291, in check_call
subprocess.CalledProcessError: Command ‘make/bind_partitions -b p3710-10-s05 linux clean’ returned non-zero exit status 1.
[2023-05-03 14:00:42,488 root ERROR pdk_bind.py 214 28232] Binding of partitions failed ! Check log for more details.
[2023-05-03 14:00:42,489 root DEBUG utilities.py 294 28232] make/Makefile.bind:50: *** CROSS_COMPILE is not defined!. Stop.
[2023-05-03 14:00:42,489 root DEBUG utilities.py 294 28232]
[2023-05-03 14:00:42,489 root DEBUG utilities.py 294 28232] ^[[01;31m***** Error: could not create boot blob *****
[2023-05-03 14:00:42,489 root DEBUG utilities.py 294 28232] ^[[0m
[2023-05-03 14:00:42,489 root DEBUG utilities.py 294 28232] ^[[01;31m ***** Error: Failed to bind the partitions *****^[[0m
[2023-05-03 14:00:42,489 root INFO runner.py 37 28232] Failed to bind partitions!
[2023-05-03 14:00:42,489 root DEBUG runner.py 39 28232] Error on line 958
[2023-05-03 14:00:42,489 root DEBUG runner.py 40 28232] Exception info: Exception Type <class ‘module.errors.FailedToBindPartitionsError’>, Traceback <traceback object at 0x7f29a91d4a08>
[2023-05-03 14:00:42,490 root INFO runner.py 45 28232] driveinstaller cannot continue! Check the log file for details: /home/z0016920/.nvsdkm/driveinstaller.log
[2023-05-03 14:00:42,490 root DEBUG runner.py 62 28232] Cleaning up…
[2023-05-03 14:00:42,490 root DEBUG utilities.py 137 28232] Deleting temporary directories…
[2023-05-03 14:00:42,490 root DEBUG utilities.py 139 28232] Deleting /tmp/pdkinstall-tmp-zvhm5dhw-bind
[2023-05-03 14:00:42,490 root DEBUG runner.py 64 28232] Closing the log file.

Yes, I was able to flash the Drive OS 6.0.5 with help of the solution of this post:

Means, I renamed drive-foundation/tools/flashtools/bootburn_t23x_py/rcm_state to drive-foundation/tools/flashtools/bootburn_t23x_py/rcm_state.bck and flashing the dev-kit was successful.

Development Kit:
Part Number: 940-63710-0010-D00
S/N: 1413022000232
Model: P3710

Dear @madison_de,
So you can flash DRIVE OS 6.0.5 now and failed to flash DRIVE OS 6.0.6 using sdkmanager?

Yes, exactly.

Dear @madison_de,
What is the DRIVE OS version on target before flashing DRIVE OS 6.0.5?

Dear @madison_de,
In the log, we could see the following error:

[2023-05-03 14:00:42,489 root DEBUG utilities.py 294 28232] make/Makefile.bind:50: *** **CROSS_COMPILE is not defined**!. Stop.

The error is caused by nv-driveos-foundation-gcc-* residue packages left on the system before installing with SDKM.
Could you check the below

  1. Uninstall build with SDKM on host
  2. Make sure “dpkg -l | grep driveos” output is empty on host.
  3. Reinstall with SDKM on host and flash the target.

Hi @SivaRamaKrishnaNV,
I uninstalled the sdkmanager with the command: sudo apt purge sdkmanager
Afterwards I checked if the ouput of “dpkg -l | grep driveos” is empty. But it isn´t empty at all.
Please see here the output of the console:

How can I remove all that files?

It seems that @SivaRamaKrishnaNV recommended that you use sdkmanager to uninstall your current DRIVE OS, instead of uninstalling sdkmanager.

Also, does installing DRIVE OS 6.0.6 with the docker container work on the devkit?

1 Like

Hi @SivaRamaKrishnaNV @VickNV,
I used the sdkmanager to uninstall the Drive OS 6.0.5. Additionaly, I uninstalled the sdkmanger itself (but i´m not sure if necessary)
Afterwards I installed the sdkmanager again and the Drive OS 6.0.6. Now the flashing of the Drive OS 6.0.6 has been finished successfully.
Thank you for your support. You can close the ticket.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.