Flashing Jetpack 5.0 for Jetson AGX with auto setup. sdkmanager wants usb id 0955:7019,7819,7919. But host pc get 0955:7020

The AGX was secondhand. It has a old OS installed.
The kernel is Linux version 4.9.201-tegra (buildbrain@mobile-u64-p211-d7000)
After boot up, I set host pc IP to It can ping each other.

However sdkmanager can not make sure AGX was in recovery mode.
It wants usb id 0955:7019,7819,7919. However lsusb in host pc side is 0955:7020.
How to resolve this issue?


If you can ping, it means your board is not in recovery mode.

When board is in recovery mode, those interfaces are not up. No OS is running when board is in recovery mode. Please manually set your board into recovery mode…

If you don’t know how to, check the quick start guide.


For my understanding, the auto setup need AGX has a IP,, this means it will use this IP to send a force-recovery command to AGX. Then AGX will go into recovery mode. After that auto setup will wait AGX run in recovery mode.

Does it mean the auto setup can’t put AGX in recovery mode? Or the AGX has a OS that is too old which can not understand sdkmanager’s force-recovery command.

I had tried manual mode with press recovery button first and power button later. But sdkmanager can not find out AGX too. Is it mean the AGX has some problem with enter recovery mode?

However I tried sdkmanager command line install. It works!!

This command works in host PC (ubuntu 20.04)

sdkmanager --cli install --logintype devzone --product Jetson --version DP_5.0 --targetos Linux --host --target JETSON_AGX_XAVIER_TARGETS --flash all


If your device is already in power-on state, then you need to use rec button + rst button instead of pwr button.

Also, I have to admit that jp5.0 is kind of new and I am not sure if there would be any bug.

If possible, you can try some old one like jp4.x to validate your steps.

I tried power down then press recovery button first then press power button. The usb id become 7019.

 use rec button + rst button instead of pwr button.

there is not such guide line in auto setup procedure.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.