The SDK says my AGX Xavier is not connected no matter what I do

I have the SDK running on Ubuntu 20.04 host computer. Does it need to be Ubuntu 16 or 18?

I have the AGX Xavier connected to the host computer at the USB-C port on the Xavier opposite side of the power port. The USB-C port right next to the light.

I’ve tried several ways of getting the AGX into recovery mode. Does it need to be in recovery mode for the SDK to connect it?
The instructions for how to get into recovery mode are not specific, so I’ve spent a few hours trying every variation. How would I know if I was even in recovery mode?
When the computer is on I hold down the recovery button and “toggle the reset button”.
Am I holding the recovery button while it’s off and pressing the power button while holding the recovery button? How long do I hold the recovery button? Do I keep holding the recovery button while pressing the reset button?
These are just a few of my questions.

For now you need Ubuntu 18.04. Probably 16.04 would work. However, if you got to the stage of flash where the unit is detected in recovery mode, and if you have put the unit in recovery, then something else is wrong. The USB-C next to the light is the correct port.

Basically you hold down the recovery button while either starting the unit or when hitting the reset button if already booted. Then let go of the recovery button. It is similar to using a shift key to get a capital letter on the keyboard (there is no requirement to keep the recovery button on).

Most often the problem is someone using a VM. VMs are not supported since a VM will not properly pass through USB in many cases, and it is up to the VM software how to fix that. If you are not using a VM, then you might have a hardware issue.

If the unit is connected via the USB-C, and if it is in recovery mode, then the host PC should see it via this command (this would work even if using Ubuntu 20.04…you just wouldn’t succeed in flashing using JetPack/SDK Manager):
lsusb -d 0955:7019

It’s not a VM and I tried it on a Ubuntu 18.04 install this morning. No dice. The light comes on but it doesn’t give any output when I start it with what should be recovery mode and I don’t see it connected to the SDK in Ubuntu.

I know this is past the warranty but what are my options for getting it fixed?

What does recovery mode look like? When the AGX is plugged in and displaying the desktop to the monitor in the normal mode, when you boot it into recovery mode does it show anything on the monitor?

No, when the board is in recovery mode, it is basically a brick. You shouldn’t see anything on the monitor or the console from any interface.

Can the SDK do a factory reset? I got the AGX Xavier recognized by the host machine. I got it in recovery mode.
It keeps asking for the AGX Xavier’s username and password but I don’t have these. This is in fact why I need to do a factory reset.

Just skip it. Those are the username/pwd after you have done your flash.

You don’t need SDK to boot up. You just need to OS.

I figured that out. I stopped the SDK when it was at step three and booted the Xavier normally and if let be setup a user and password.
Strange to me that the SDK asks for a user and password before one is setup.

California added a new law regarding default name/password, and so although the flash software used to provide a default login name and password this had to be removed. Thus the software to set up the account on first boot. Plus of course a password is needed on the host PC for some of the “root only” operations.

Interesting. That would explain the inexplicable break in the install process.
Maybe all technology companies should move to Texas or Miami.

…then they would not be able to sell products in California.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.