Flashing Jetpack to TX2 not finishing using SDKmanager

I have tried to use the SDKmanager to flash Jetpack 4.3 and also 4.2.3 to the TX2 module, both time the flashing stopped at 99.8%

I copied the final lines of the log below.

10:38:38 INFO : Flash Jetson TX2 : Bootloader is not running on device.
10:38:38 INFO : Flash Jetson TX2 : [ 9.0467 ]
10:38:38 INFO : Flash Jetson TX2 : [ 10.0498 ] tegrarcm_v2 --isapplet
10:55:34 INFO : Flash Jetson TX2 : [ 1019.7518 ]
10:55:34 INFO : Flash Jetson TX2 : [ 1019.7544 ] tegradevflash_v2 --iscpubl
10:57:34 INFO : Flash Jetson TX2 : [ 1019.7563 ] C
11:12:29 INFO : Flash Jetson TX2 : PU Bootloader is not running on device.
11:12:29 INFO : Flash Jetson TX2 : [ 2035.5588 ]
11:12:29 INFO : Flash Jetson TX2 : [ 2036.5640 ] tegrarcm_v2 --isapplet

Does anyone know why the flashing won’t finish?

If the host PC is a VM, then this tends to lose USB. Is your host a regular Ubuntu PC, or is there anything unusual about it (like being a VM)?

I am using an intel NUC running Ubuntu version 16.04 LTS

I have actually heard of issues using the Intel NUC (USB issues). I am uncertain as to what the specific issue was, or if it was ever resolved.

Would someone here happen to remember anything about issues flashing from an Intel NUC? This might be the issue, but then again, it could still be something else.

Mine is doing the same, I am on ubuntu 18.04 VM flashing a TX2 and jetpack 4.3. lsusb and the like still ready connection to the TX2. Same exact lines of code as posted by OP in the log.

VMs are not supported as they tend to require extra setup to not lose USB or virtual wired ethernet during the process. VMs can be made to work, but there is no official support for that. Typically it involves making sure the USB owned wholly by the guest o/s and that disconnect and reconnect of USB remains part of the guest o/s. The NUC problem is a different issue, and hopefully someone will remember if there was a workaround.

Yea I saw your previous comments about VMs not being supported. I get it, doesn’t make it less of an option just one that hasn’t been figured out and Nvidia keeps crashing their support. I do agree that VMs should be supported. Especially because I did this install with 4.2.3 not even a month ago through VirtualBox with no problems. Yes, had to use filter and what not to make it connect, use the extension pack and so on, but it worked. I think their documentation leaves some to be desired. That is what makes your comments extremely helpful. I really appreciate your comments as I have been shifting these forums for days and see you have contributed a lot! Seriously, thank you!!!

That being said, I switched after this comment to VMware from VirtualBox, and it worked well and I got through flashing. I have hit another issue with it not installing the SDK components, but I know it is specifically due to the very unique situation of what I am trying to accomplish. Thanks again @linuxdev!!

Need to clarify that VMware or VB are not supported here. When we claim “no support” here, it means these options are not going through QA test. It does not mean 100% not working on each person’s case.

When you hit some flash problems, please also share the flash log “from your device” through UART.

The issue is not same as the Xavier issue (stuck at 99.8%…) because TX2 and Xavier are not using the same MB1 bootloader and that error only happens to Xavier MB1.

Interesting, nice to know. So it is a completely different issue from the other forum. Unfortunately, I didn’t grab the logs when I was using VirtualBox. Thanks for the response!

Can flashing be done over Ethernet?

If you do get a chance to flash again and need information on serial console, see: