FlexLM shutdown from clients

Hi

I have come over a somehow strange problem behaviour of our system.

We have a Cluster with the Portland CDK running (on the master node == FlexLM host). Additionally there are a few Workstations for the develeopers running PGI Compiler.

Somehow since a few weeks, the FlexLM is beeing shut down on the Cluster master node. I see the following in the log:

16:28:09 (lmgrd) SHUTDOWN request from root at node eule

16:28:09 (lmgrd) lmgrd will now shut down all the vendor daemons

16:28:09 (lmgrd) Shutting down pgroupd pid=20131 because of signal 15

16:28:09 (pgroupd) Shutdown requested from > root@keam.gap.fzk.de > IP=172.27.80.120

16:28:09 (pgroupd) daemon shutdown requested - shutting down

16:28:09 (pgroupd) IN: “pgi90-cdk-linux” haas@cauchy (SHUTDOWN)

16:28:09 (pgroupd) IN: “pgi-dbg” haas@cauchy (SHUTDOWN)

16:28:09 (pgroupd) IN: “pgi-dbg-gui” haas@cauchy (SHUTDOWN)

16:28:09 (lmgrd) Shut down FLEXnet pgroupd license server system on machine keam.gap.fzk.de

16:28:09 (lmgrd) EXITING DUE TO SIGNAL 15

The client euler (should actually be euler) / cauchy are development machines running Suse Linux 10.x and 11. They have PGI 9.0 installed. The license is made available by the modules packeg (evnironment settings manager)

prepend-path PATH /opt/pgi/linux86-64/9.0/bin
prepend-path LD_LIBRARY_PATH /opt/pgi/linux86-64/9.0/lib:/opt/pgi/linux86-64/9.0/libso
prepend-path MANPATH /opt/pgi/linux86-64/9.0/man
setenv LM_LICENSE_FILE 27000@keam
setenv PGI /opt/pgi

Does anybody have an idea about the reason for this behaviour ???
or any solutions??? (I am running nagios on the cluster master and I could integrate the flexlm into magion, but then the reason for the problem will still exist!)

Regards fro snowy Garmisch-Partenkirchen
Edwin

Edwin,

  1. Please send the entire flexlm.log file to license@pgroup.com

  2. Also send the license file you are using.

  3. Are you running the compilers on the same machine that the
    license server is running on?

  4. If you have a firewall, does turning it off solve the problem for you?

thanks,
dave