Friction coefficient setting not working on gpu PhysX

I’m attempting to tune an environment with a wheeled differential drive robot, I’m using spheres for the wheels’ collision shape. For testing, I’m setting the PlaneParams dynamic and static frictions to 0 and all the robot rigid shape properties frictions to 0.0. With the use_gpu PhysX param disabled, the wheel turns and speeds ups without the robot moving (slipping) as expected, however, the wheels do not slip when I enable GPU PhysX

It’s the same for me, all friction zero, but the robot still moves. When it moves, the linear velocity matches what I set, but the angular velocity is always much smaller. But when I set to different friction coefficients, the movement does change. Example, 0 friction move much slower than some positive values.