[GeForce GTX 860M] Nvidia driver not starting under Debian 10 Buster


I tried to install nvidia-driver on Debian Buster but it does not seem to work. On startup, it says that nvidia-persistence.service did not start : " nvidia-persistenced failed to initialize."
nvidia-detect tells me that nvidia-driver is the recommended package for my GeForce GTX 860M. Please note that only the Intel GPU is currently running on my OS and that I am unable to change it to the Nvidia card because the Nvidia switcher does not start (it is a Optimus laptop).
I also tried beforehand the Nvidia installer (.run), to no avail. I still have the log of the installer in my log files, so I attach it to this message.
Thank you for your assistance.

nvidia-bug-report.log (502.6 KB)
nvidia-installer.log (3.9 KB)

The driver is unloaded and bbswitch is used to turn off the nvidia gpu. Seems you have bumblebee installed. Does optirun work?

To be honest, I tried to install primus this afternoon. My X server would not start anymore and I had to reinstall my OS nvidia-bug-report.log (1.9 MB) on my fresh install. I installed nvidia-driver, nvidia-smi, nvidia-driver-libs-i386, nvidia-vulkan-icd and nvidia-vulkan-icd-i386. The main problem is that nvidia-settings does not start. nvidia-settings -V says :

WARNING: NV-CONTROL extension not found on this Display.

ERROR: Unable to load info from any available system

Furthermore, nvidia-smi seems to tell that the graphic card is off :

Mon May 11 20:55:45 2020       
| NVIDIA-SMI 418.113      Driver Version: 418.113      CUDA Version: N/A      |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce GTX 860M    On   | 00000000:01:00.0 Off |                  N/A |
| N/A   56C    P8    N/A /  N/A |      0MiB /  4046MiB |      0%      Default |
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|  No running processes found                                                 |

optirun is not installed anymore.

Please see this:
Optimus Howto