Linux driver do not recognize/work with GTX-1070

Hello together,

I have tried to install the nvidia-driver on my new laptop in two different ways with the same result - it didn’t work out. The installation was done on a fresh debian (Linux version 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2 (2017-04-30))

Version-a)
I install the “nvidia-driver” with the package-manager - the installation ran without problems.
After reboot the system starts the KDE-desktop with the “Nouveau-driver”.
Calling “nvidia-settings” gave the confimation that the system currently does not use the
nvidia-driver and I should run “nvidia-xconfig” to set the necessary settings automatically.

Calling “nvidia-xconfig” failed cause the file wasn`t available in the system.

Version-b)
I reset the system with the image I do before installing the driver - so it is fresh again and download the current driver-version from the nvidia-homepage (NVIDIA-Linux-x86_64-375.66.run).
Stop the x-server and start to install the driver from tty1.
Installation ran without problems - I accept the “automatical update of the x-configuration”.
After reboot the system comes up in tty1. The x-server on tty7 seems to run but there is only blinking courser.

Please find attach the appropriate logs and bug-reports.

https://www.dropbox.com/sh/9imdjwapd3ag06d/AAB_voBApm0mD9yeXB09_Yu7a?dl=0

Thank’s for help / pexx

This is an Optimus Laptop, what’s the setting in Bios, looks like it’s set to ‘Hybrid’. You will then have to configure it to use Prime or switch to ‘Discrete’
But anyway

  • nouveau has to be blacklisted
  • since it looks like a Clevo with known problems, add
acpi_osi=! acpi_osi="Windows 2009"

to your kernel parameters in case of freezes.

Please untick ‘Answer accepted’, it looks like you found a solution.

Your notebook system has two GPU = Intel and Nvidia

[ 2.252] (–) PCI:*(0:0:2:0) 8086:191b:1558:6a01 rev 6, Mem @ 0x2ffe000000/16777216, 0x80000000/268435456, I/O @ 0x0000f000/64
[ 2.253] (–) PCI: (0:1:0:0) 10de:1ba1:1558:6a01 rev 161, Mem @ 0xdb000000/16777216, 0x90000000/268435456, 0xa0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x???/524288

Check if you can disable Intel GPU from bios settings. Is nvidia-prime package available for Debian? This will auto configure display offloading. Other you have to go thought below links :

https://download.nvidia.com/XFree86/Linux-x86_64/381.22/README/optimus.html
https://download.nvidia.com/XFree86/Linux-x86_64/381.22/README/optimus.html

Hello,

the magic word seems to be DISCRETE. I have changed the settings in the BIOS and the graphics card is running. - Thanks for that.
By changing the settings there is an effect that the grub screen appears slowly - not a big deal - at least I see that the changes take effect.
The output of ‘lsmod’ shows both modules for NVIDIA and Nouveau. With an additional “blacklist.conf” the nouveau driver is not loaded at the start, but had no further effects.
After the “sleep mode” the screen does not wake up - hibernation is fine. Login-manager appears very small, characters and input fields do not match - is this something I can influence or depence it on the hardware?

With the changed BIOS settings I tried again the installation with the package manager with the result that KDE starts however the nvidia driver is not used by the system with reference to ‘nvidia-xconfig’ but which does not exist.
The output of ‘/etc/modprobe.d/’ shows symbolic links to ‘Blacklist-Nouveau’. The review of ‘lsmod’ gave neither a reference to “NVIDIA” nor “Nouveau”.
Well, while I’m testing here, there’s a bug on the machine - bios freezing - (a new laptop). So it seems that I have to wait for the support to return the device.
Please note additional information.

https://www.dropbox.com/sh/9imdjwapd3ag06d/AAB_voBApm0mD9yeXB09_Yu7a?dl=0

Thanks / Pexx

Use the kernel parameters I mentioned for suspend/resume to work.