GeForce RTX 3060 display unclaimed on Ubuntu 20.04.3 (New PC)

I am setting up a new system which came with an RTX 3060.
The nvidia driver is installed

$ dkms status
nvidia, 510.47.03, 5.13.0-27-generic, x86_64: installed

However, it is not running:

$ nvidia-smi 
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I’ve been reading through these forums trying various recommendations and nothing has helped so far. I have tried purging and reinstalling nvidia-driver-510 (with update-initramfs, nvidia-xconfig, and undoing nvidia-xconfig), setting pci=realloc, and adding Option "PrimaryGPU" "Yes" to 10-nvidia.conf to no avail.

Nothing in dmesg stood out to me.

$ modinfo nvidia
filename:       /lib/modules/5.13.0-27-generic/updates/dkms/nvidia.ko


$ sudo insmod nvidia
insmod: ERROR: could not load module nvidia: No such file or directory

(the .ko file is present on the filesystem)

Anything else I should investigate based on the bug report?
nvidia-bug-report.log.gz (136.8 KB)

Update: I got it resolved this morning. I think it may have been a secure boot issue. Here’s what fixed it for me:

apt remove --purge nvidia*
ubuntu-drivers autoinstall

If you’re using secure boot, be ensure to select “enroll” instead of “continue with boot” when the MOK screen comes up.