GeForce RTX 3060 LHR not working neither with Ubuntu 20.04 or Ubuntu 22.04


  • Nuvo 8208GC
  • 2x NVIDIA RTX 3060 Low Hash Rate 12 Gb GPU

I’ve been trying to get GPUs work with Ubuntu. I’ve tried so far:

  • Installing various versions of NVIDIA drivers (470, 525, 510, etc)
  • Installing varios versions of OS: Ubuntu 22.04, Ubuntu 20.04
  • I even tried using 2x RTX 2080 GPUs
  • Installing Windows 11

But with Ubuntu I always get the same problem: After installing nvidia-drivers I just get black screen on the display connected to gpus.

And nvidia-smi says

no devices were found

There are some failures from nvidia-bug-report:

RmInitAdapter failed
rm_init_adapter failed, device minor number
Failed to register device
Failed to allocate NvKmsKapiDevice

$ uname -s -r
Linux 5.15.0-56-generic

But GPUs works perfectly with Windows 11 on the same hardware (I have dual boot rn)

I will appreciate so much any kind of advice or help here

Upd1. Uploaded dmsg log:
dmesg.log (89.0 KB)

Need more info. Example dmesg

@RomanAverin Uploaded dmsg log.

Same problem

Try updating your Motherboard BIOS

1 Like

Neousys board, see

1 Like