GeForce RTX 3070, 3660T doesn't get detected, rather LLVM, OpenGL shows 3.1

Dear team,

There are multiple problems which I am currently facing with the NVIDIA driver 470.141.03. Please find the details of nvidia-smi.
| NVIDIA-SMI 470.141.03 Driver Version: 470.141.03 CUDA Version: 11.4 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
| 0 NVIDIA GeForce … Off | 00000000:01:00.0 Off | N/A |
| 0% 37C P8 11W / 220W | 1MiB / 7982MiB | 0% Default |
| | | N/A |

| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
| No running processes found |


  1. The OpenGL version is 3.1 (OpenGL version string: 3.1 Mesa 20.0.8) and I want this to be updated to 3.3+. While my research I found that this come tightly coupled with nvidia graphics. I saw 3070 can have 4.6 OpenGL version but then why it shows v3.1 for OpenGL.
  2. What should be the kernel version to install nvidia-470.143.03 ?
  3. I have installed the nvidia driver-470 which is a recommended version and when trying to reboot the system, it gets stuck with error dev/nvme0n1p2 clean and gets stuck with some files and blocks getting cleared. I had to purge nvidia and then reboot the system. This happened for 1-2 times. I can access the main PC by remote but main screen of the PC still shows the nvm0n1p2 error.
  4. After some tries I managed to install 470 driver from “software and updates” but there are some commands which doesn’t work such as nvidia-settings etc. These checks I am performing through remote access as the main PC still shows the nvm0n1p2 error.
  5. Why it shows LLVM as Graphics and not nvidia.
  6. nvidia-settings return ERROR: Unable to load info from any available system. “(nvidia-settings:7293): GLib-GObject-CRITICAL **: 17:23:38.776: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
    ** Message: 17:23:38.778: PRIME: No offloading required. Abort
    ** Message: 17:23:38.778: PRIME: is it supported? no”

OS: ubuntu 18.04.6 LTS
Processor: 12th Gen Intel Core-i7-12700 X 20
Graphics: llvmpipe(LLVM 10.0.0 256 bits
OS type: 64 bit
Kernel version: 5.4.0-131-generic.

Please find the bug reort attached.

nvidia-bug-report.log.gz (1.1 MB)
Please find the bug report

Remote access connects to a virtual Xserver running on software.
The real Xserver doesn’t run at all but is continuously crashing due to the 12th gen intel igpu still being active and the kernel being too old.

Thanks for your reply,

What I understood from your comment is that:

  1. Update the Kernel
  2. Blacklist intel igpu


  1. Does the remote access creates some problem? I have installed xrdp to take remote access of Linux PC.


I tried installing the Kernel 5.17.15 and installed it. But the headers for 5.17.15 didn’t get installed giving some dependency error with libc6 and libssl3. Could you tell me what would be the right version of kernel that can be installed with nvidia-470 ? I also found a link from the forum but didn’t get much info : Ubuntu 18.04 cannot boot after installing recommended nvidia driver 470 - Graphics / Linux / Linux - NVIDIA Developer Forums .

Update: I tried installing liquonix but there also I have a dependency with libc6 version and libssl3 version. Is there any way to resolve this problem. I wonder how a user has instlled the liquonix kernel in the post: No display / NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver - #2 by generix

I also read it that libc6 can’t be upgraded to >= 3.0 because of the dependency with 18.04 ubuntu.

Using the liquorix ppa is the correct way to upgrade the kernel. This also shouldn’t have any dependency on non-18.04 libc/libssl. Please remove the manually installed 5.17.15 kernel.

I have removed the manually installed linux and still I get the error as below: Please see the screenshot attached. There is only 1 kernel left and that is

The version of ubuntu is 18.04.06. Will it be better that I freshly install the ubuntu and then do it.

Seems the liquorix ppa cancelled support for 18.04.

Thanks for your reply.
Is there any other way to make nvidia driver work for my configuration ?

You should disable the intel graphics in bios so the nvidia gpu is the only one.

I confirmed with liquorix that they have stopped supporting ubuntu 18.04.

Steps performed to make the driver worked:

  1. Re-install ubuntu 18.04.06 (I wanted to make sure everything is clean)
  2. Disable the intel gpu from Bios and select Nvidia GPU.
  3. Install the recommended driver (in my case it is nvidia-470)
  4. reboot the system
  5. Check for OpenGL version (showed 4.6.0)
  6. checked nvidia-smi. It shows the version of driver: 470.141.03.

Thanks for the support generix.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.