Getting Python Working with Isaac Sim Launcher App

Hi There
I am trying to setup Python environment to work with Isaac Sim launched by Omniverse launcher. I couldn’t find " Python mini app" nor the root “_build/linux-x86_64/release” so that I run
./python.sh -m pip install -r python_samples/requirements.txt
from.
Could you please clarify the steps on how to setup Python with the launcher?

Thanks
HA

Hi, you can follow these step to run that command:

  1. Launch Isaac Sim from the Omniverse Launcher.
  2. On the Isaac Sim App Launcher, click the Open in Terminal button. A terminal window should pop-up
  3. Run ./python.sh -m pip install -r python_samples/requirements.txt

Thanks @Sheikh_Dawood for the prompt response.
I actually did that and then tried running some sample code but keep getting various errors:

  1. tried calling Jetbot sample with this:
    ./python.sh python_samples/jetbot/jetbot.py

here is the error message:

Traceback (most recent call last):
File “python_samples/jetbot/jetbot.py”, line 3, in
from pxr import UsdGeom, Gf, UsdPhysics
File “/home/user/.local/share/ov/pkg/isaac_sim-2021.1.0/kit/extscore/omni.usd.libs/pxr/UsdGeom/init.py”, line 24, in
from . import _usdGeom
ImportError: /home/user/.local/share/ov/pkg/isaac_sim-2021.1.0/kit/extscore/omni.usd.libs/bin/libjs.so: undefined symbol: _ZN32pxrInternal_v0_20__pxrReserved__18Tf_PostErrorHelperERKNS_13TfCallContextENS_16TfDiagnosticTypeEPKcz
There was an error running python

  1. tried the second method through a conda environment and ran:
    python python_samples/jetbot/jetbot.py

and here is the error:

Traceback (most recent call last):
File “python_samples/jetbot/jetbot.py”, line 1, in
import carb
ModuleNotFoundError: No module named ‘carb’

which probably means that the path to the modules are not set.

Please advise.

thanks
HA

To run the JetBot sample, run:
./python.sh python_samples/jetbot/jetbot_train.py
Please see JetBot Lane Following Sample