gmsl camera problem

Hi, we had a problem on camera.

I remembered that the gmsl camera worked well until yesterday.

but today when we try to capture the camera with “sample_camera_gmsl”, the comera doesn’t work.

the strange thing is that AGX_B working well. but only AGX_A doens’t work.

the error message is below. thank you

nvidia@tegra-ubuntu:/usr/local/driveworks/bin$ sudo ./sample_camera_gmsl_raw

[11-07-2019 10:38:44] Platform: Detected DDPX - Tegra A
[11-07-2019 10:38:44] Initialize DriveWorks SDK v2.0.2081
[11-07-2019 10:38:44] Release build with GNU 4.9.4 from heads/buildbrain-branch-0-g36b127f against Drive PDK v5.1.0.2
[11-07-2019 10:38:44] TimeSource: monotonic epoch time offset is 1562813533214901
[11-07-2019 10:38:44] PTP Time is available from NVPPS Driver
[11-07-2019 10:38:44] Platform: number of GPU devices detected 2
[11-07-2019 10:38:44] Platform: currently selected GPU device discrete ID 0
[11-07-2019 10:38:44] SDK: Resources mounted from /usr/local/driveworks-2.0/data/
[11-07-2019 10:38:44] SDK: Create NvMediaDevice
[11-07-2019 10:38:44] SDK: use EGL display as provided
[11-07-2019 10:38:44] Initialize DriveWorks VisualizationSDK v2.0.2081
[11-07-2019 10:38:44] Initialize DriveWorksGL SDK v2.0.2081
[11-07-2019 10:38:44] SensorFactory::createSensor() -> camera.gmsl, output-format=raw+data,camera-type=ar0231-rccb-bae-sf3324,camera-group=a,format=raw,fifo-size=3,slave=0
[11-07-2019 10:38:44] CameraGMSL: Create NvMediaIPPManager
[11-07-2019 10:38:44] CameraGMSL: required FPS = 30, resolution = 1920x1208
nvmedia isc: IscPwrCtrlInit: 939: Camera power control library: NVCCP
Max96712 Rev 2 detected!
MAX96712: Enable periodic AEQ on Link 0
MAX96705: Pre-emphasis set to 0xaa
Sensor AR0231 RCCB Rev7 detected!
(NvCapture) Error IoctlFailed: capture setup ioctl failed: 5 (in /dvs/git/dirty/git-master_linux/camera/capture/nvcapture/capture_hw_linux.c, function NvCaptureLinuxChannelOpen(), line 157)
(NvCapture) Error IoctlFailed: (propagating from /dvs/git/dirty/git-master_linux/camera/capture/nvcapture/capture.c, function NvCaptureChannelHwBackendOpen(), line 1169)
(NvCapture) Error IoctlFailed: (propagating from /dvs/git/dirty/git-master_linux/camera/capture/nvcapture/capture.c, function NvCaptureChannelSetAttribute(), line 1241)
SetSourceSequence: failed to set channel source attribute
ICPCreate: captureCreate failed
CreateGroup: failed for create ICP instance 0
[IppIcpExComponentCreateNew:634] Failed to create ICP
[NvMediaIPPComponentCreateNew:806] Failed to create NVMEDIA_IPP_COMPONENT_ICP_EX component
[11-07-2019 10:38:51] Driveworks exception thrown: DW_NVMEDIA_ERROR: CameraGMSL: Cannot setup pipeline : 7

terminate called after throwing an instance of ‘std::runtime_error’
what(): [2019-07-11 10:38:51] DW Error DW_NVMEDIA_ERROR executing DW function:
dwSAL_createSensor(&m_camera, params, m_sal)
at /dvs/git/dirty/gitlab-master_av/dw/sdk/samples/sensors/camera/camera_gmsl_raw/main.cpp:178
Aborted (core dumped)

Dear jw31,

Could you please refer to below link for your topic?

https://devtalk.nvidia.com/default/topic/1056310/general/sw9-0-gmsl-camera-sample-fails-to-run/